rpi-userland: provides OpenGL ES, EGL and OpenVG
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Mar 2013 10:22:48 +0000 (10:22 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 6 Mar 2013 21:18:39 +0000 (22:18 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/opengl/libegl/libegl.mk
package/opengl/libgles/libgles.mk
package/opengl/libopenvg/libopenvg.mk
package/rpi-userland/Config.in

index 56cc8ac0d6ca55dcc9bf59f38e25e5b26302866f..c4954963c8e99efc268aa31179085d750c85dfe8 100644 (file)
@@ -6,6 +6,10 @@
 
 LIBEGL_SOURCE =
 
+ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
+LIBEGL_DEPENDENCIES += rpi-userland
+endif
+
 ifeq ($(LIBEGL_DEPENDENCIES),y)
 define LIBEGL_CONFIGURE_CMDS
        echo "No libEGL implementation selected. Configuration error."
index 753f53efe1f8f8f90427cbd2e273db42114af69a..f0d0eec9c375d6bf77bec5fc752adab6b613d1f0 100644 (file)
@@ -6,6 +6,10 @@
 
 LIBGLES_SOURCE =
 
+ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
+LIBGLES_DEPENDENCIES += rpi-userland
+endif
+
 ifeq ($(LIBGLES_DEPENDENCIES),y)
 define LIBGLES_CONFIGURE_CMDS
        echo "No libGLES implementation selected. Configuration error."
index 2fcc99fa3b23fb93404b533b4367f38f062879e3..573fa786dd2a9e6dbc8f118a77e2bdeec00ff2af 100644 (file)
@@ -6,6 +6,10 @@
 
 LIBOPENVG_SOURCE =
 
+ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
+LIBOPENVG_DEPENDENCIES += rpi-userland
+endif
+
 ifeq ($(LIBOPENVG_DEPENDENCIES),y)
 define LIBOPENVG_CONFIGURE_CMDS
        echo "No libOpenVG implementation selected. Configuration error."
index 58ea8cb5935193de80b44e8cfea5482ba7127fb5..2c35fb76c87ab37e7108eafb76a35c7647a1a156 100644 (file)
@@ -3,6 +3,9 @@ config BR2_PACKAGE_RPI_USERLAND
        depends on BR2_arm
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_LARGEFILE
+       select BR2_PACKAGE_HAS_OPENGL_EGL
+       select BR2_PACKAGE_HAS_OPENGL_ES
+       select BR2_PACKAGE_HAS_OPENVG
        help
          Raspberry Pi Userland contains the necessary library to use the
          VideoCore driver.