package/aufs: add support for linux 5.x
authorAlexey Lukyanchuk <skif@skif-web.ru>
Tue, 25 Feb 2020 12:29:13 +0000 (15:29 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 26 Feb 2020 19:51:45 +0000 (20:51 +0100)
Signed-off-by: Alexey Lukyanchuk <skif@skif-web.ru>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/Config.ext.in
package/aufs/aufs.mk

index 14140d352cd5889a26ceb584b1fac7aec447f5c0..734a52a53306909f3ef3cbede1d3101c9cee9c5c 100644 (file)
@@ -102,7 +102,8 @@ choice
        help
          Select the major series of this version. This must match the
          major version of your kernel (e.g. for kernels 3.x, select
-         aufs3.x; for kernels 4.x, select aufs4.x).
+         aufs3.x; for kernels 4.x, select aufs4.x; for kernels 5.x,
+         select aufs5.x ).
 
          Note: neither aufs1.x nor aufs2.x (both for kernels older than
          3.x) are supported.
@@ -113,12 +114,16 @@ config BR2_LINUX_KERNEL_EXT_AUFS_SERIES_3
 config BR2_LINUX_KERNEL_EXT_AUFS_SERIES_4
        bool "aufs4.x"
 
+config BR2_LINUX_KERNEL_EXT_AUFS_SERIES_5
+       bool "aufs5.x"
+
 endchoice
 
 config BR2_LINUX_KERNEL_EXT_AUFS_SERIES
        int
        default 3 if BR2_LINUX_KERNEL_EXT_AUFS_SERIES_3
        default 4 if BR2_LINUX_KERNEL_EXT_AUFS_SERIES_4
+       default 5 if BR2_LINUX_KERNEL_EXT_AUFS_SERIES_5
 
 config BR2_LINUX_KERNEL_EXT_AUFS_VERSION
        string "aufs-standalone version"
@@ -135,6 +140,8 @@ config BR2_LINUX_KERNEL_EXT_AUFS_VERSION
          https://sourceforge.net/p/aufs/aufs3-standalone/ref/master/branches/
          For aufs4.x:
          https://github.com/sfjro/aufs4-standalone/branches/all
+         For aufs5.x:
+         https://github.com/sfjro/aufs5-standalone/branches/all
 
 endif # aufs
 
index 55dbf942dfa1bc5b44b40f62041aef9c64cad6e5..4e95a350a028b8a10cbdbf40a09468a2833dbc53 100644 (file)
@@ -13,6 +13,8 @@ AUFS_SITE = http://git.code.sf.net/p/aufs/aufs3-standalone
 AUFS_SITE_METHOD = git
 else ifeq ($(BR2_PACKAGE_AUFS_SERIES),4)
 AUFS_SITE = $(call github,sfjro,aufs4-standalone,$(AUFS_VERSION))
+else ifeq ($(BR2_PACKAGE_AUFS_SERIES),5)
+AUFS_SITE = $(call github,sfjro,aufs5-standalone,$(AUFS_VERSION))
 endif
 
 ifeq ($(BR_BUILDING):$(BR2_PACKAGE_AUFS):$(AUFS_VERSION),y:y:)