beecrypt: only build C++ support if dependencies are available
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Mar 2014 15:01:32 +0000 (16:01 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Mar 2014 15:01:32 +0000 (16:01 +0100)
Instead of automatically pulling in the (big) icu library if the toolchain
dependencies are available.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/beecrypt/Config.in
package/beecrypt/beecrypt.mk

index 8d63e5e6d1370cb515bcd0012cda261858235dbf..84754e5343a7356d637f3297c37a88e7bbc5e589 100644 (file)
@@ -1,8 +1,6 @@
 config BR2_PACKAGE_BEECRYPT
        bool "beecrypt"
        depends on BR2_TOOLCHAIN_HAS_THREADS
-       select BR2_PACKAGE_ICU if BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR && \
-              !BR2_arc && !BR2_BINFMT_FLAT
        help
          Beecrypt is a general-purpose cryptography library.
 
@@ -10,8 +8,3 @@ config BR2_PACKAGE_BEECRYPT
 
 comment "beecrypt needs a toolchain w/ threads"
        depends on !BR2_TOOLCHAIN_HAS_THREADS
-
-comment "beecrypt C++ support needs a toolchain w/ wchar"
-       depends on !BR2_arc
-       depends on !BR2_BINFMT_FLAT
-       depends on BR2_INSTALL_LIBSTDCPP && !BR2_USE_WCHAR && BR2_TOOLCHAIN_HAS_THREADS
index 223b44fb334a9554e179c123a1ac7f310807ffc2..c77782c81335f125db86a14a956fc7a28e3bb195 100644 (file)
@@ -22,7 +22,7 @@ BEECRYPT_CONF_OPT = \
                --without-python \
                --disable-openmp
 
-ifeq ($(BR2_PACKAGE_ICU),y)
+ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_USE_WCHAR)$(BR2_PACKAGE_ICU),yyy)
 # C++ support needs icu
 BEECRYPT_DEPENDENCIES += icu
 else