erlang: pass erl_xcomp_sysroot to configure
authorFrank Hunleth <fhunleth@troodon-software.com>
Fri, 13 Sep 2013 15:46:01 +0000 (11:46 -0400)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Sep 2013 13:18:24 +0000 (15:18 +0200)
This is required for building the 'crypto', 'odbc', 'ssh'
and 'ssl' Erlang applications. These apps are skipped
regardless of whether they're enabled and their dependencies
can be met if this environment variable isn't set.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/erlang/erlang.mk

index 89104c95fa24571d79228badc7fee13e6d817ce8..b2197408b7306a265a34e266b5fa8ca0d7cfcc32 100644 (file)
@@ -17,6 +17,10 @@ ERLANG_INSTALL_STAGING = YES
 # The configure checks for these functions fail incorrectly
 ERLANG_CONF_ENV = ac_cv_func_isnan=yes ac_cv_func_isinf=yes
 
+# Set erl_xcomp variables. See xcomp/erl-xcomp.conf.template
+# for documentation.
+ERLANG_CONF_ENV += erl_xcomp_sysroot=$(STAGING_DIR)
+
 ERLANG_CONF_OPT = --without-javac
 HOST_ERLANG_CONF_OPT = --without-javac