makedevs: remove target package
authorArnout Vandecappelle <arnout@mind.be>
Wed, 23 Nov 2016 14:14:04 +0000 (15:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Nov 2016 22:12:06 +0000 (23:12 +0100)
The makedevs package is a fork of the makedevs tool from busybox. It is
part of the Buildroot infrastructure, not something that should be used
on the target. It something like this is needed on the target, upstream
busybox should be used. And if one of the Buildroot-specific features
is needed, then that feature should be upstreamed to busybox.

Besides, there were already two things wrong with the target package:
- it didn't take into account the overlap with busybox (no depends on
  BR2_PACKAGE_BUSYBOX_SHOW_OTHERS, no dependency on busybox);
- it didn't take into account the libcap feature.

The target package was introduced more or less accidentally in 81cd9d45
where the intention was to make it more similar to other packages.

So, kill it with fire.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/Config.in
package/makedevs/Config.in [deleted file]
package/makedevs/makedevs.mk

index c0b84980b667871192d29d9d4dfcff7d6257f148..cfb127610a13fc4eb35288d4c80955969812f87d 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2017.02"
 
+config BR2_PACKAGE_MAKEDEVS
+       bool "makedevs removed"
+       select BR2_LEGACY
+       help
+         The makedevs tool is part of busybox. The Buildroot fork
+         should not be used outside of the Buildroot infrastructure.
+
 config BR2_TOOLCHAIN_EXTERNAL_ARAGO_ARMV7A
        bool "Arago ARMv7 2011.09 removed"
        select BR2_LEGACY
index b2e1a2a41ba90022de3e3de611702f46e8fa50c6..b076dfd8b1c19aacc605871ee1de666065b264ce 100644 (file)
@@ -170,7 +170,6 @@ menu "Filesystem and flash utilities"
        source "package/genext2fs/Config.in"
        source "package/genpart/Config.in"
        source "package/genromfs/Config.in"
-       source "package/makedevs/Config.in"
        source "package/mmc-utils/Config.in"
        source "package/mtd/Config.in"
        source "package/mtools/Config.in"
diff --git a/package/makedevs/Config.in b/package/makedevs/Config.in
deleted file mode 100644 (file)
index 923150d..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-config BR2_PACKAGE_MAKEDEVS
-       bool "makedevs"
-       help
-         The makedevs utility allows to create a set of device files
-         according to a configuration file.
index 95933c4f4e540cb7a44e59cca0ab7159dcb5eda8..9bd684f0363bd9a4d53d685e9e5a369ffe0c2ba4 100644 (file)
@@ -15,15 +15,6 @@ HOST_MAKEDEVS_CFLAGS += -DEXTENDED_ATTRIBUTES
 HOST_MAKEDEVS_LDFLAGS += -lcap
 endif
 
-define MAKEDEVS_BUILD_CMDS
-       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
-               package/makedevs/makedevs.c -o $(@D)/makedevs
-endef
-
-define MAKEDEVS_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 755 $(@D)/makedevs $(TARGET_DIR)/usr/sbin/makedevs
-endef
-
 define HOST_MAKEDEVS_BUILD_CMDS
        $(HOSTCC) $(HOST_MAKEDEVS_CFLAGS) package/makedevs/makedevs.c \
                -o $(@D)/makedevs $(HOST_MAKEDEVS_LDFLAGS)
@@ -33,5 +24,4 @@ define HOST_MAKEDEVS_INSTALL_CMDS
        $(INSTALL) -D -m 755 $(@D)/makedevs $(HOST_DIR)/usr/bin/makedevs
 endef
 
-$(eval $(generic-package))
 $(eval $(host-generic-package))