package/time: New package for GNU time.
authorWill Newton <will.newton@gmail.com>
Fri, 19 Oct 2012 03:05:17 +0000 (03:05 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 20 Oct 2012 19:09:58 +0000 (21:09 +0200)
Signed-off-by: Will Newton <will.newton@imgtec.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/time/Config.in [new file with mode: 0644]
package/time/time.mk [new file with mode: 0644]

index d7b3db6ebc5b6c0e6616e96635bd0476ad35c669..dd4c97ec1f63074fd50e4bc8ad5c7eb459a568e7 100644 (file)
@@ -672,6 +672,7 @@ source "package/logsurfer/Config.in"
 source "package/screen/Config.in"
 source "package/sudo/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
+source "package/time/Config.in"
 source "package/which/Config.in"
 endif
 source "package/xmlstarlet/Config.in"
diff --git a/package/time/Config.in b/package/time/Config.in
new file mode 100644 (file)
index 0000000..634d41a
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_TIME
+       bool "time"
+       help
+         The GNU time utility.
+
+         http://savannah.gnu.org/projects/time/
diff --git a/package/time/time.mk b/package/time/time.mk
new file mode 100644 (file)
index 0000000..7b53286
--- /dev/null
@@ -0,0 +1,17 @@
+#############################################################
+#
+# time
+#
+#############################################################
+
+TIME_VERSION = 1.7
+TIME_SITE = $(BR2_GNU_MIRROR)/time
+TIME_CONF_ENV = ac_cv_func_wait3=yes
+
+# time uses an old version of automake that does not support
+# installing in DESTDIR.
+define TIME_INSTALL_TARGET_CMDS
+       install -D -m 755  $(@D)/time $(TARGET_DIR)/usr/bin/time
+endef
+
+$(eval $(autotools-package))