bison: fix m4 dependency
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Dec 2011 20:39:02 +0000 (21:39 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Dec 2011 20:46:36 +0000 (21:46 +0100)
Bison needs m4 (at runtime). In addition, the bison 2.5 configure script
checks for m4 4.1.6 or newer, and bails out otherwise, but ends up looking
at whatever the build host has rather than the cross version, which might
not be the correct version (or even available).

Fix it by short circuiting the check.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bison/Config.in
package/bison/bison.mk

index e8aa0b60f0ede0045af046da7e85d3bda6e9c48c..da0ac3f1ef896064597dc91c0801b820f5ff79c6 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_BISON
        bool "bison"
        depends on BR2_USE_WCHAR
+       select BR2_PACKAGE_M4
        help
          General-purpose parser generator that converts a
          grammar description for an LALR context-free grammar into a C
index 759592e166352884b15949386153d0190025eedc..c277e96ad048b4c23d575f815f76ebd510368d98 100644 (file)
@@ -7,11 +7,16 @@
 BISON_VERSION = 2.5
 BISON_SITE = $(BR2_GNU_MIRROR)/bison
 
+BISON_CONF_ENV += ac_cv_path_M4=/usr/bin/m4
+BISON_DEPENDENCIES += m4
+
 define BISON_DISABLE_EXAMPLES
        echo 'all install:' > $(@D)/examples/Makefile
 endef
 
 BISON_POST_CONFIGURE_HOOKS += BISON_DISABLE_EXAMPLES
 
+HOST_BISON_DEPENDENCIES += host-m4
+
 $(eval $(call AUTOTARGETS))
 $(eval $(call AUTOTARGETS,host))