mplayer: tighten alsa dependency
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Nov 2010 12:09:14 +0000 (13:09 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Nov 2010 12:10:23 +0000 (13:10 +0100)
mplayer needs pcm+mixer support in alsa, but this isn't checked by
configure, so do it in mplayer.mk instead.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/multimedia/mplayer/mplayer.mk

diff --git a/CHANGES b/CHANGES
index d92425db77c471aabde1573e16f2544b33f60c52..e436f8748b087c3472a69efe7ec9dfb17b57ad63 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        libintl, libmms, libmpd, libnl, liboil, libosip2, libpcap,
        libpng, libtool, libungif, libxml2, libxslt, lighttpd, lite,
        lm-sensors, lockfile-progs, logrotate, m4, mdadm, mesa3d,
-       metacity, mtd-utils, mysql_client, nano, nbd, ncftp, neon,
-       netperf, netsnmp, ng-spice-rework, ntfsprogs, ntp, openntpd,
-       openssh, openssl, openvpn, oprofile, pango, patch, pcre, php,
-       pkg-config, pppd, prboom, radvd, rdesktop, ruby, qt, quagga,
-       samba, sawman, sdl_mixer, sdl_sound, setserial,
+       metacity, mplayer, mtd-utils, mysql_client, nano, nbd, ncftp,
+       neon, netperf, netsnmp, ng-spice-rework, ntfsprogs, ntp,
+       openntpd, openssh, openssl, openvpn, oprofile, pango, patch,
+       pcre, php, pkg-config, pppd, prboom, radvd, rdesktop, ruby,
+       qt, quagga, samba, sawman, sdl_mixer, sdl_sound, setserial,
        shared-mime-info, speex, sqlite, squashfs,
        startup-notification, strace, sylpheed, taglib, tcpdump,
        thttpd, tiff, tn5250, torsmo, udev, udpcast, usbmount,
index ac3a67e1d555c5603edb6bcd7cca06583d91b35f..93e38dab80c2faf22bf0eb6d540ff3ef51932b29 100644 (file)
@@ -11,9 +11,15 @@ MPLAYER_CAT:=$(BZCAT)
 MPLAYER_BINARY:=mplayer
 MPLAYER_TARGET_BINARY:=usr/bin/$(MPLAYER_BINARY)
 
-MPLAYER_DEPENDENCIES = \
-       $(if $(BR2_PACKAGE_LIBMAD),libmad) \
-       $(if $(BR2_PACKAGE_ALSA_LIB),alsa-lib)
+MPLAYER_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBMAD),libmad)
+
+# mplayer needs pcm+mixer support, but configure fails to check for it
+ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yyy)
+MPLAYER_DEPENDENCIES += alsa-lib
+MPLAYER_ALSA:=--enable-alsa
+else
+MPLAYER_ALSA:=--disable-alsa
+endif
 
 ifeq ($(BR2_ENDIAN),"BIG")
 MPLAYER_ENDIAN:=--enable-big-endian
@@ -84,6 +90,7 @@ $(MPLAYER_DIR)/.configured: $(MPLAYER_DIR)/.unpacked
                $(MPLAYER_LARGEFILE) \
                $(MPLAYER_SDL) \
                $(MPLAYER_FREETYPE) \
+               $(MPLAYER_ALSA) \
                --enable-cross-compile \
                --disable-ivtv \
                --disable-tv \