package/nginx: add stream return option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 22 Jun 2020 19:31:12 +0000 (21:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 22 Jun 2020 20:44:29 +0000 (22:44 +0200)
stream return module has been added in version 1.11.2 with
https://github.com/nginx/nginx/commit/a7c6f8c1d7cb817bf84b639ee0933f9ffed05275
and is enabled by default, add an option to be able to disable it

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nginx/Config.in
package/nginx/nginx.mk

index 64406664d3dacd7b383d5e484de25d5ac42ab93b..cad5903882c9ed3e9181792024e3e5805c859ef3 100644 (file)
@@ -352,6 +352,12 @@ config BR2_PACKAGE_NGINX_STREAM_MAP_MODULE
        help
          Enable ngx_stream_map_module
 
+config BR2_PACKAGE_NGINX_STREAM_RETURN_MODULE
+       bool "ngx_stream_return_module"
+       default y
+       help
+         Enable ngx_stream_return_module
+
 config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_HASH_MODULE
        bool "ngx_stream_upstream_hash_module"
        default y
index 1ff59e7f971f83034964b3ce171de1fe78a9e679..344d41d410b7d24db8355c9fcedeb464e77edd58 100644 (file)
@@ -233,6 +233,7 @@ NGINX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE),,--without-stream_limit_conn_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE),,--without-stream_access_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_MAP_MODULE),,--without-stream_map_module) \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_RETURN_MODULE),,--without-stream_return_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_HASH_MODULE),,--without-stream_upstream_hash_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_LEAST_CONN_MODULE),,--without-stream_upstream_least_conn_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_ZONE_MODULE),,--without-stream_upstream_zone_module)