mpd: add optional libmpdclient dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 3 Apr 2018 20:03:41 +0000 (22:03 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Apr 2018 20:51:51 +0000 (22:51 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/Config.in
package/mpd/mpd.mk

index bad32f84405c3802e53b04669dbe717e7617ca85..6c7468e173cca631f2a881128d0fbe9dcbe29a73 100644 (file)
@@ -285,6 +285,12 @@ config BR2_PACKAGE_MPD_AVAHI_SUPPORT
 comment "avahi support needs a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS
 
+config BR2_PACKAGE_MPD_LIBMPDCLIENT
+       bool "libmpdclient"
+       select BR2_PACKAGE_LIBMPDCLIENT
+       help
+         Enable libmpdclient support.
+
 config BR2_PACKAGE_MPD_NEIGHBOR_DISCOVERY_SUPPORT
        bool "neighbor discovery support"
        depends on BR2_PACKAGE_MPD_LIBSMBCLIENT || BR2_PACKAGE_MPD_UPNP
index f50e3d90c7e60359a64ee59ef84adba476e6855b..639c8c198158be4b409566b53fc47df588d4665e 100644 (file)
@@ -113,6 +113,13 @@ else
 MPD_CONF_OPTS += --disable-lame-encoder
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_LIBMPDCLIENT),y)
+MPD_DEPENDENCIES += libmpdclient
+MPD_CONF_OPTS += --enable-libmpdclient
+else
+MPD_CONF_OPTS += --disable-libmpdclient
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_LIBNFS),y)
 MPD_DEPENDENCIES += libnfs
 MPD_CONF_OPTS += --enable-nfs