libnspr: fix 64-bit build
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 10 Jul 2012 22:25:45 +0000 (00:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Jul 2012 21:49:10 +0000 (23:49 +0200)
On some architectures (found on x86_64, but probably others too),
libnspr builds with -m32 unless it is configured for 64-bit build.  So
force 64-bit build on 64-bit architectures.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libnspr/libnspr.mk

index c2cc99685127cc2a4d47a65ca84c2a8f1f05f5ce..689caa424cce1646fcdadc463cf9fa3f62c77c6c 100644 (file)
@@ -12,6 +12,8 @@ LIBNSPR_INSTALL_STAGING = YES
 LIBNSPR_CONF_ENV = HOST_CFLAGS="-g -O2" \
                   HOST_LDFLAGS="-lc"
 # NSPR mixes up --build and --host
-LIBNSPR_CONF_OPT = --host=$(GNU_HOST_NAME)
+LIBNSPR_CONF_OPT  = --host=$(GNU_HOST_NAME)
+LIBNSPR_CONF_OPT += --$(if $(BR2_ARCH_IS_64),en,dis)able-64bit
+LIBNSPR_CONF_OPT += --$(if $(BR2_INET_IPV6),en,dis)able-ipv6
 
 $(eval $(autotools-package))