- pass the correct endian
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 20 Apr 2007 11:12:50 +0000 (11:12 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 20 Apr 2007 11:12:50 +0000 (11:12 -0000)
package/netsnmp/netsnmp.mk

index 09184c7b09f652fa6c32ba7f598454868825cbb5..34b28cbe3409f643d598eb64ff9f3424ae5ee822 100644 (file)
@@ -22,6 +22,12 @@ $(NETSNMP_DIR)/.unpacked: $(DL_DIR)/$(NETSNMP_SOURCE) $(DL_DIR)/$(NETSNMP_PATCH1
        toolchain/patch-kernel.sh $(NETSNMP_DIR) package/netsnmp/ netsnmp\*.patch
        touch $(NETSNMP_DIR)/.unpacked
 
+ifeq ($(BR2_ENDIAN),"BIG")
+NETSNMP_ENDIAN=big
+else
+NETSNMP_ENDIAN=little
+endif
+
 # We set CAN_USE_SYSCTL to no and use /proc since the
 # sysctl code in this thing is apparently intended for
 # freebsd or some such thing...
@@ -37,7 +43,7 @@ $(NETSNMP_DIR)/.configured: $(NETSNMP_DIR)/.unpacked
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \
-               --with-endianness=little \
+               --with-endianness=$(NETSNMP_ENDIAN) \
                --with-persistent-directory=/var/lib/snmp \
                --enable-ucd-snmp-compatibility \
                --enable-shared \