readline: bump to version 6.2pl1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 26 Apr 2011 14:56:49 +0000 (11:56 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Apr 2011 18:45:38 +0000 (20:45 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/readline/readline-6.1-curses-link.patch [deleted file]
package/readline/readline-6.2-curses-link.patch [new file with mode: 0644]
package/readline/readline-6.2-pl1.patch [new file with mode: 0644]
package/readline/readline.mk

diff --git a/package/readline/readline-6.1-curses-link.patch b/package/readline/readline-6.1-curses-link.patch
deleted file mode 100644 (file)
index 56b4770..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-link readline directly to ncurses since it needs symbols from it
-
-upstream readline does this on purpose (no direct linking), but
-it doesn't make much sense in a Linux world
-
---- a/support/shobj-conf
-+++ b/support/shobj-conf
-@@ -42,7 +42,7 @@
- SHOBJ_LIBS=
- SHLIB_XLDFLAGS=
--SHLIB_LIBS=
-+SHLIB_LIBS=-lncurses
- SHLIB_DOT='.'
- SHLIB_LIBPREF='lib'
diff --git a/package/readline/readline-6.2-curses-link.patch b/package/readline/readline-6.2-curses-link.patch
new file mode 100644 (file)
index 0000000..56b4770
--- /dev/null
@@ -0,0 +1,16 @@
+link readline directly to ncurses since it needs symbols from it
+
+upstream readline does this on purpose (no direct linking), but
+it doesn't make much sense in a Linux world
+
+--- a/support/shobj-conf
++++ b/support/shobj-conf
+@@ -42,7 +42,7 @@
+ SHOBJ_LIBS=
+ SHLIB_XLDFLAGS=
+-SHLIB_LIBS=
++SHLIB_LIBS=-lncurses
+ SHLIB_DOT='.'
+ SHLIB_LIBPREF='lib'
diff --git a/package/readline/readline-6.2-pl1.patch b/package/readline/readline-6.2-pl1.patch
new file mode 100644 (file)
index 0000000..9ef0e48
--- /dev/null
@@ -0,0 +1,29 @@
+Bug-Reported-by:       Clark J. Wang <dearvoid@gmail.com>
+Bug-Reference-ID:      <AANLkTimGbW7aC4E5infXP6ku5WPci4t=xVc+L1SyHqrD@mail.gmail.com>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2011-02/msg00157.html
+
+diff -Nura readline-6.2/callback.c readline-6.2-pl1/callback.c
+--- readline-6.2/callback.c    2010-06-06 13:18:58.000000000 -0300
++++ readline-6.2-pl1/callback.c        2011-04-19 14:20:00.269829168 -0300
+@@ -148,6 +148,9 @@
+         eof = _rl_vi_domove_callback (_rl_vimvcxt);
+         /* Should handle everything, including cleanup, numeric arguments,
+            and turning off RL_STATE_VIMOTION */
++        if (RL_ISSTATE (RL_STATE_NUMERICARG) == 0)
++         _rl_internal_char_cleanup ();
++
+         return;
+       }
+ #endif
+diff -Nura readline-6.2/vi_mode.c readline-6.2-pl1/vi_mode.c
+--- readline-6.2/vi_mode.c     2010-11-20 21:51:39.000000000 -0300
++++ readline-6.2-pl1/vi_mode.c 2011-04-19 14:19:24.510586785 -0300
+@@ -1114,7 +1114,7 @@
+       rl_beg_of_line (1, c);
+       _rl_vi_last_motion = c;
+       RL_UNSETSTATE (RL_STATE_VIMOTION);
+-      return (0);
++      return (vidomove_dispatch (m));
+     }
+ #if defined (READLINE_CALLBACKS)
+   /* XXX - these need to handle rl_universal_argument bindings */
index 9e25e04a137ffbe841eb0cc943e928bb74acadf4..e34c6506d7685c7f6ee6fd094bc0ee8d3c388f28 100644 (file)
@@ -3,7 +3,8 @@
 # build GNU readline
 #
 #############################################################
-READLINE_VERSION = 6.1
+
+READLINE_VERSION = 6.2
 READLINE_SOURCE = readline-$(READLINE_VERSION).tar.gz
 READLINE_SITE = $(BR2_GNU_MIRROR)/readline
 READLINE_INSTALL_STAGING = YES