libembryo: Add new package
authorWill Newton <will.newton@gmail.com>
Thu, 26 Jan 2012 17:42:39 +0000 (17:42 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 29 Jan 2012 19:04:59 +0000 (20:04 +0100)
[Peter: add upstream URL, remove redundant _INSTALL_TARGET]
Signed-off-by: Will Newton <will.newton@imgtec.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/Config.in
package/efl/libembryo/Config.in [new file with mode: 0644]
package/efl/libembryo/libembryo.mk [new file with mode: 0644]

index 30077839856cbfb7f7a4ae34550e0337627bb264..0e27dab7e5460a2d6bc39314fdca66f40263cc00 100644 (file)
@@ -12,6 +12,7 @@ source "package/efl/libeina/Config.in"
 source "package/efl/libecore/Config.in"
 source "package/efl/libeet/Config.in"
 source "package/efl/libevas/Config.in"
+source "package/efl/libembryo/Config.in"
 
 endif # BR2_PACKAGE_EFL
 
diff --git a/package/efl/libembryo/Config.in b/package/efl/libembryo/Config.in
new file mode 100644 (file)
index 0000000..63c7064
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBEMBRYO
+       bool "libembryo"
+       select BR2_PACKAGE_LIBEINA
+       help
+         Embryo is primarily a shared library that gives you an API
+         to load and control interpreted programs compiled into an
+         abstract machine bytecode that it understands.
+
+         http://trac.enlightenment.org/e/wiki/Embryo
diff --git a/package/efl/libembryo/libembryo.mk b/package/efl/libembryo/libembryo.mk
new file mode 100644 (file)
index 0000000..0054ff4
--- /dev/null
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libembryo
+#
+#############################################################
+
+LIBEMBRYO_VERSION = 1.1.0
+LIBEMBRYO_SOURCE = embryo-$(LIBEMBRYO_VERSION).tar.bz2
+LIBEMBRYO_SITE = http://download.enlightenment.org/releases/
+LIBEMBRYO_INSTALL_STAGING = YES
+
+LIBEMBRYO_DEPENDENCIES = host-pkg-config libeina
+
+$(eval $(call AUTOTARGETS))
+$(eval $(call AUTOTARGETS,host))