libpcap: handle bluetooth explicitly
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 4 Aug 2014 01:38:49 +0000 (22:38 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 4 Aug 2014 07:43:42 +0000 (09:43 +0200)
If bluez_utils is around then add it to dependencies so as to use it,
but if it's not (for instance bluez5_utils is around) then disable it
since the bluez5 API isn't compatible. Fixes:
http://autobuild.buildroot.net/results/6ca/6caeb7f41ac5e14dbee49f87511af3351f6013f1/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libpcap/libpcap.mk

index a8c056ea3d8212a1468192539bd233462a9991e8..7cf731eb86baafe04995eb135796e8b68336ef22 100644 (file)
@@ -20,6 +20,13 @@ LIBPCAP_CFLAGS = $(TARGET_CFLAGS)
 LIBPCAP_CONF_OPT = --disable-yydebug --with-pcap=linux
 LIBPCAP_CONFIG_SCRIPTS = pcap-config
 
+# On purpose, not compatible with bluez5
+ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
+LIBPCAP_DEPENDENCIES += bluez_utils
+else
+LIBPCAP_CONF_OPT += --disable-bluetooth
+endif
+
 ifeq ($(BR2_PACKAGE_DBUS),y)
 LIBPCAP_CONF_OPT += --enable-dbus
 LIBPCAP_DEPENDENCIES += dbus