package/sysrepo: drop unneeded dependencies
authorHeiko Thiery <heiko.thiery@gmail.com>
Thu, 16 Apr 2020 12:18:16 +0000 (14:18 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 17 Apr 2020 11:17:30 +0000 (13:17 +0200)
The following dependencies are no longer needed:
- libev
- libavl
- protobuf-c

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/sysrepo/Config.in
package/sysrepo/sysrepo.mk

index 31f817faa166a52ee66695b2f453b3b0def3f309..8de141efc25ef68ee81bc6beb63ab3a72ae442c4 100644 (file)
@@ -5,13 +5,9 @@ config BR2_PACKAGE_SYSREPO
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
-       depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86" # host-protobuf
-       select BR2_PACKAGE_LIBAVL
-       select BR2_PACKAGE_LIBEV
        select BR2_PACKAGE_LIBYANG
        select BR2_PACKAGE_PCRE
        select BR2_PACKAGE_PCRE_UCP
-       select BR2_PACKAGE_PROTOBUF_C
        help
          Sysrepo is an YANG-based configuration and operational state
          data store for Unix/Linux applications.
@@ -31,4 +27,3 @@ comment "sysrepo needs a toolchain w/ C++, NPTL, dynamic library, gcc >= 4.8"
        depends on BR2_USE_MMU
        depends on BR2_STATIC_LIBS || !BR2_INSTALL_LIBSTDCPP \
                || !BR2_TOOLCHAIN_HAS_THREADS_NPTL
-       depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
index 0ca4d2591e3cafaeb94e6c26021c24649fa48ce2..67290dad4fdf3b27eaafca4fe89f443e307ddf1c 100644 (file)
@@ -9,8 +9,8 @@ SYSREPO_SITE = $(call github,sysrepo,sysrepo,v$(SYSREPO_VERSION))
 SYSREPO_INSTALL_STAGING = YES
 SYSREPO_LICENSE = Apache-2.0
 SYSREPO_LICENSE_FILES = LICENSE
-SYSREPO_DEPENDENCIES = libev libavl libyang pcre protobuf-c host-sysrepo
-HOST_SYSREPO_DEPENDENCIES = host-libev host-libavl host-libyang host-pcre host-protobuf-c
+SYSREPO_DEPENDENCIES = libyang pcre host-sysrepo
+HOST_SYSREPO_DEPENDENCIES = host-libyang host-pcre
 
 SYSREPO_CONF_OPTS = \
        -DCMAKE_BUILD_TYPE=Release \