ruby: fix verconf.h related build failure
authorPeter Seiderer <ps.report@gmx.net>
Fri, 5 Dec 2014 23:23:35 +0000 (00:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Jan 2015 16:55:37 +0000 (17:55 +0100)
See [1] for failure analysis.

Fixes:
   http://autobuild.buildroot.net/results/c94fef5d2cfb00a336905ae3c110d7680f6d5416/
   http://autobuild.buildroot.net/results/4375cb1e325a336dbf59f22f975be9165ad0648a/

[1] http://lists.busybox.net/pipermail/buildroot/2014-December/114273.html

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ruby/ruby.mk

index 20a2a11be2fb1942c6d18ab116cdcd7f5d95a148..00a785ca2bf4aebf7eded444c7a761ecfeb9bb25 100644 (file)
@@ -64,6 +64,13 @@ else
        RUBY_CONF_OPTS += --without-gmp
 endif
 
+# workaround for amazing build failure, see
+# http://lists.busybox.net/pipermail/buildroot/2014-December/114273.html
+define RUBY_REMOVE_VERCONF_H
+       rm -f $(@D)/verconf.h
+endef
+RUBY_POST_CONFIGURE_HOOKS += RUBY_REMOVE_VERCONF_H
+
 # Remove rubygems and friends, as they need extensions that aren't
 # built and a target compiler.
 RUBY_EXTENSIONS_REMOVE = rake* rdoc* rubygems*