arch/csky: add support for the ck860 core
authorGuo Ren <ren_guo@c-sky.com>
Fri, 31 May 2019 06:39:00 +0000 (14:39 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 31 May 2019 20:59:57 +0000 (22:59 +0200)
ck860 is newest CPU core of C-SKY with high performance & SMP
supported.

Signed-off-by: Guo Ren <ren_guo@c-sky.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
arch/Config.in.csky
arch/arch.mk.csky

index ebde7fe476d06ba1a8df3b385f6750d75e2cefb6..4bdfbfae4b81d911cfb157875ed30a546141e2d6 100644 (file)
@@ -13,11 +13,14 @@ config BR2_ck807
 config BR2_ck810
        bool "ck810"
 
+config BR2_ck860
+       bool "ck860"
+
 endchoice
 
 config BR2_CSKY_FPU
        bool "Enable FPU coprocessor"
-       depends on BR2_ck810 || BR2_ck807
+       depends on BR2_ck810 || BR2_ck807 || BR2_ck860
        help
          You can say N here if your C-SKY CPU doesn't have a
          Floating-Point Coprocessor or if you don't need FPU support
index f2c90eb206035046ebd6504aa8b802a77ed905d6..fb59ae22fd3206f5c5a4fe4260ed7965bb9bafe5 100644 (file)
@@ -11,6 +11,8 @@ else ifeq ($(BR2_ck807),y)
 GCC_TARGET_CPU := ck807
 else ifeq ($(BR2_ck810),y)
 GCC_TARGET_CPU := ck810
+else ifeq ($(BR2_ck860),y)
+GCC_TARGET_CPU := ck860
 endif
 
 ifeq ($(BR2_CSKY_FPU),y)