rsyslog: use the more traditional --{enable,disable}
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Jan 2015 21:06:23 +0000 (22:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Jan 2015 21:06:23 +0000 (22:06 +0100)
Instead of using --enable-<foo>={yes,no}, use
--{enable,disable}-<foo>, like we do in most other packages.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsyslog/rsyslog.mk

index b13baecaf4438f7fdda20dfb0a4b8cd88583e605..fe28d2fcd7e4487889bd12a39dce40f2b8471010 100644 (file)
@@ -31,9 +31,9 @@ endif
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 RSYSLOG_DEPENDENCIES += libgcrypt
 RSYSLOG_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
-RSYSLOG_CONF_OPTS += --enable-libgcrypt=yes
+RSYSLOG_CONF_OPTS += --enable-libgcrypt
 else
-RSYSLOG_CONF_OPTS += --enable-libgcrypt=no
+RSYSLOG_CONF_OPTS += --disable-libgcrypt
 endif
 
 ifeq ($(BR2_PACKAGE_MYSQL),y)