efl/libeio: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 24 Dec 2012 11:23:27 +0000 (12:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Dec 2012 06:21:58 +0000 (07:21 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/Config.in
package/efl/libeio/Config.in [new file with mode: 0644]
package/efl/libeio/libeio.mk [new file with mode: 0644]

index c783d7f078f919d669db65d15c18612b9ca577cf..a526d87a4df08bb2c70bcfb34dd30f62ee93f181 100644 (file)
@@ -13,6 +13,7 @@ source "package/efl/libeina/Config.in"
 source "package/efl/libecore/Config.in"
 source "package/efl/libeet/Config.in"
 source "package/efl/libefreet/Config.in"
+source "package/efl/libeio/Config.in"
 source "package/efl/libevas/Config.in"
 source "package/efl/libembryo/Config.in"
 source "package/efl/libedje/Config.in"
diff --git a/package/efl/libeio/Config.in b/package/efl/libeio/Config.in
new file mode 100644 (file)
index 0000000..0b2751c
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_LIBEIO
+       bool "libeio"
+       select BR2_PACKAGE_LIBEET
+       select BR2_PACKAGE_LIBEINA
+       select BR2_PACKAGE_LIBECORE
+       help
+         Eio integrates with EFL (Ecore, Eina) to provide efficient
+         filesystem Input/Output (I/O). It use the best techniques to
+         achieve such purpose, like using at-variants, splice,
+         properly handling errors and doing it in an asynchronous
+         fashion by means of worker threads. It is also ported to
+         Windows, so multi-platform.
+
+         Whenever you need to list a directory, copy, move or delete
+         files, Eio will do that task better than you'd achieve with
+         naive implementations, and it is easy to use.
+
+         http://trac.enlightenment.org/e/wiki/Eio
diff --git a/package/efl/libeio/libeio.mk b/package/efl/libeio/libeio.mk
new file mode 100644 (file)
index 0000000..f5e08de
--- /dev/null
@@ -0,0 +1,16 @@
+#############################################################
+#
+# libeio
+#
+#############################################################
+
+LIBEIO_VERSION = 1.7.4
+LIBEIO_SOURCE = eio-$(LIBEIO_VERSION).tar.bz2
+LIBEIO_SITE = http://download.enlightenment.org/releases/
+LIBEIO_LICENSE = LGPLv2.1
+LIBEIO_LICENSE_FILES = COPYING
+
+LIBEIO_INSTALL_STAGING = YES
+LIBEIO_DEPENDENCIES = libeina libeet libecore
+
+$(eval $(autotools-package))