can-utils: bump to version 2018.02.0
authorBaruch Siach <baruch@tkos.co.il>
Fri, 4 May 2018 09:23:47 +0000 (12:23 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 6 May 2018 07:09:42 +0000 (09:09 +0200)
Disable for musl. can-utils now uses the error() glibc extension.

Use Makefile as license file.

Change homepage link to the github repo. The README.md file is much more
informative than the elinux.org wiki page.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/can-utils/Config.in
package/can-utils/can-utils.hash
package/can-utils/can-utils.mk

index bfa522d9899e3a3f4e2db3bf1ecb2447b7144442..1800eca042dadd09d6d7e81995b59cc42a3c25e7 100644 (file)
@@ -2,13 +2,14 @@ config BR2_PACKAGE_CAN_UTILS
        bool "can-utils"
        depends on BR2_USE_MMU # fork()
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # clock_nanosleep()
+       depends on !BR2_TOOLCHAIN_USES_MUSL # error()
        help
          SocketCAN is a set of open source CAN drivers and a
          networking stack.
          This package provides various tools for this stack.
 
-         http://elinux.org/Can-utils
+         https://github.com/linux-can/can-utils
 
-comment "can-utils needs a toolchain w/ NPTL"
-       depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL
+comment "can-utils needs a glibc or uClibc toolchain w/ NPTL"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_TOOLCHAIN_USES_MUSL
        depends on BR2_USE_MMU
index 64c4cf6692c5ed840cfac5cc754f0001a0776bf2..2034c35a874f2d48fa4ffca7435c31629c31590e 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed
-sha256  c4b6b347c1c165a64c1156bb8816bce557945dd770f61b8bdc8fdb7c0744af27  can-utils-c3305fdd515464153d20199db232b6124bc962c0.tar.gz
+sha256  370ad4b19447c29099f7300548f1a3362d6e123c4a6a827dbbd3110bc2c26839  can-utils-v2018.02.0.tar.gz
+sha256  c258939ebb09c3857f5fc7704a449e5077cc881090c87b38f9a81332b96fa075  Makefile
index 45d5e29fecee1c9d6184a5bd16e848a6ae55092c..bff4d21fef0bf3af8a26f82627a78bf4702a3a64 100644 (file)
@@ -4,9 +4,10 @@
 #
 ################################################################################
 
-CAN_UTILS_VERSION = c3305fdd515464153d20199db232b6124bc962c0
+CAN_UTILS_VERSION = v2018.02.0
 CAN_UTILS_SITE = $(call github,linux-can,can-utils,$(CAN_UTILS_VERSION))
 CAN_UTILS_LICENSE = BSD-3-Clause or GPL-2.0, GPL-2.0+
+CAN_UTILS_LICENSE_FILES = Makefile
 CAN_UTILS_AUTORECONF = YES
 
 $(eval $(autotools-package))