batctl: new package
authorJens Zettelmeyer <zettelmeyerj@gmail.com>
Mon, 9 Feb 2015 20:22:18 +0000 (20:22 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 9 Feb 2015 21:45:58 +0000 (22:45 +0100)
[Thomas:
 - remove trailing whitespace
 - remove "# libnl" comment in Config.in
 - remove BATCTL_SOURCE, which is not needed, since the default value
   is used
 - pass $(TARGET_CONFIGURE_OPTS) in the make environment, not as a
   make option, otherwise the CFLAGS += lines of batctl Makefile do
   not have any effect, and lead to not have the proper include path
   to the libnl header files.]

Signed-off-by: Jens Zettelmeyer <zettelmeyerj@goooglemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/batctl/Config.in [new file with mode: 0644]
package/batctl/batctl.hash [new file with mode: 0644]
package/batctl/batctl.mk [new file with mode: 0644]

index fe3d3d06d96d9b78d51b061167d5d35965dae53f..b9d67535dbf50f789e7573dca27ad27293d60e83 100644 (file)
@@ -1055,6 +1055,7 @@ menu "Networking applications"
        source "package/avahi/Config.in"
        source "package/axel/Config.in"
        source "package/bandwidthd/Config.in"
+       source "package/batctl/Config.in"
        source "package/bcusdk/Config.in"
        source "package/bind/Config.in"
        source "package/bluez_utils/Config.in"
diff --git a/package/batctl/Config.in b/package/batctl/Config.in
new file mode 100644 (file)
index 0000000..a60f4f6
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_BATCTL
+       bool "batctl"
+       depends on BR2_INET_IPV6
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libnl
+       select BR2_PACKAGE_LIBNL
+       help
+         Batctl is the configuration and debugging tool for batman-adv.
+
+         http://www.open-mesh.org/projects/batman-adv/wiki/Using-batctl
+
+comment "batctl needs a toolchain w/ IPv6, threads"
+       depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/batctl/batctl.hash b/package/batctl/batctl.hash
new file mode 100644 (file)
index 0000000..663e602
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 77509ed70232ebc0b73e2fa9471ae13b12d6547d167dda0a82f7a7fad7252c36  batctl-2014.4.0.tar.gz
diff --git a/package/batctl/batctl.mk b/package/batctl/batctl.mk
new file mode 100644 (file)
index 0000000..c458752
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# batctl
+#
+################################################################################
+
+BATCTL_VERSION = 2014.4.0
+BATCTL_SITE = http://downloads.open-mesh.org/batman/releases/batman-adv-$(BATCTL_VERSION)
+BATCTL_LICENSE = GPLv2
+BATCTL_DEPENDENCIES = libnl host-pkgconf
+
+define BATCTL_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) all
+endef
+
+define BATCTL_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               PREFIX=/usr DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))