package/python3-psutil: add a special host variant
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 23 Mar 2020 10:49:08 +0000 (11:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 Apr 2020 14:27:11 +0000 (16:27 +0200)
Needed to build mongodb.

With this host variant there is no need to enforce host
python in the original package.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-psutil/python-psutil.mk
package/python3-psutil/python3-psutil.hash [new symlink]
package/python3-psutil/python3-psutil.mk [new file with mode: 0644]

index 5f87e723ccbba6daf5416fff6b6c87459ffe5c5b..08bb2fd7bd1abf206284ffd25b4869b0b10a15d2 100644 (file)
@@ -4,6 +4,7 @@
 #
 ################################################################################
 
+# Please keep in sync with package/python3-psutil/python3-psutil.mk
 PYTHON_PSUTIL_VERSION = 5.7.0
 PYTHON_PSUTIL_SOURCE = psutil-$(PYTHON_PSUTIL_VERSION).tar.gz
 PYTHON_PSUTIL_SITE = https://files.pythonhosted.org/packages/c4/b8/3512f0e93e0db23a71d82485ba256071ebef99b227351f0f5540f744af41
diff --git a/package/python3-psutil/python3-psutil.hash b/package/python3-psutil/python3-psutil.hash
new file mode 120000 (symlink)
index 0000000..ff688fa
--- /dev/null
@@ -0,0 +1 @@
+../python-psutil/python-psutil.hash
\ No newline at end of file
diff --git a/package/python3-psutil/python3-psutil.mk b/package/python3-psutil/python3-psutil.mk
new file mode 100644 (file)
index 0000000..ddd4b6b
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# python3-psutil
+#
+################################################################################
+
+# Please keep in sync with package/python-psutil/python-psutil.mk
+PYTHON3_PSUTIL_VERSION = 5.7.0
+PYTHON3_PSUTIL_SOURCE = psutil-$(PYTHON3_PSUTIL_VERSION).tar.gz
+PYTHON3_PSUTIL_SITE = https://files.pythonhosted.org/packages/c4/b8/3512f0e93e0db23a71d82485ba256071ebef99b227351f0f5540f744af41
+PYTHON3_PSUTIL_SETUP_TYPE = setuptools
+PYTHON3_PSUTIL_LICENSE = BSD-3-Clause
+PYTHON3_PSUTIL_LICENSE_FILES = LICENSE
+HOST_PYTHON3_PSUTIL_DL_SUBDIR = python-psutil
+HOST_PYTHON3_PSUTIL_NEEDS_HOST_PYTHON = python3
+
+$(eval $(host-python-package))