pv: support ccache builds
authorAndrew Ruder <andrew.ruder@elecsyscorp.com>
Fri, 15 Nov 2013 20:28:56 +0000 (14:28 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 17 Nov 2013 07:36:49 +0000 (08:36 +0100)
When using ccache TARGET_CC is something like
    ccache gcc

This causes problems in the pv build which attempts to
override LD because the command ends up being
    make [...] LD=/tools/ccache /tools/gcc LDFLAGS="[...]

As a result, during the build phase it attempts to build
/tools/gcc which succeeds by doing nothing:
    make[1]: Nothing to be done for `/tools/gcc'.

and during the install phase you get the real build which
errors out on the LD error this snippet was attempting to
fix:
    ld -r -o src/library.o src/library/getopt.o \
        src/library/gettext.o
    ld: src/library/gettext.o: Relocations in generic ELF \
        (EM: 40)
    src/library/gettext.o: error adding symbols: File in \
        wrong format

Signed-off-by: Andrew Ruder <andrew.ruder@elecsyscorp.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pv/pv.mk

index 00502d3b4e39833ee8802d74b9528d57a9382b3b..5f1a54bdada27d79f7fa27bd2c324d4d764eed14 100644 (file)
@@ -17,7 +17,7 @@ PV_LICENSE_FILES = doc/COPYING
 # the correct one. By passing the below values for LD and LDFLAGS, we
 # ensure that 'gcc' is used to do these partial linking steps.
 PV_MAKE_OPT = \
-       LD=$(TARGET_CC) \
+       LD="$(TARGET_CC)" \
        LDFLAGS="-Wl,-r -nostdlib"
 
 $(eval $(autotools-package))