dependencies: additional check for PERL_MM_OPT
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 14 Oct 2011 07:50:02 +0000 (09:50 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Oct 2011 21:01:03 +0000 (23:01 +0200)
When the user has Perl local::lib installed, its environment contains
a PERL_MM_OPT variables which defines
INSTALL_BASE="/some/location". Unfortunately, having this makes the
build of libxml-parser-perl (and probably other Perl related packages)
fail, because it complains that both PREFIX (passed in our .mk file)
and INSTALL_BASE (passed from the PERL_MM_OPT environment variable)
are defined. Since in Buildroot we want our PREFIX to be considered,
we error out when the user has PERL_MM_OPT defined.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/dependencies/dependencies.sh

index 410f663fab65f1021960591e44c69218d48b7e1d..2b9c0b373cfd053ba4d419e34643fcdf9cc37142 100755 (executable)
@@ -40,6 +40,14 @@ if test -n "$PATH" ; then
        fi
 fi;
 
+if test -n "$PERL_MM_OPT" ; then
+    /bin/echo -e "\nYou have PERL_MM_OPT defined because Perl local::lib"
+    /bin/echo -e "is installed on your system. Please unset this variable"
+    /bin/echo -e "before starting Buildroot, otherwise the compilation of"
+    /bin/echo -e "Perl related packages will fail"
+    exit 1
+fi
+
 # Verify that which is installed
 if ! which which > /dev/null ; then
        /bin/echo -e "\nYou must install 'which' on your build machine\n";