efl/libevas: remove SVG support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 28 Dec 2012 15:35:02 +0000 (16:35 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Dec 2012 06:21:58 +0000 (07:21 +0100)
The SVG support requires esvg, which hasn't been released yet. The
recommandation of the EFL developers is to use the SVG loader from the
evas-generic-loaders project.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libevas/Config.in
package/efl/libevas/libevas.mk

index ddac49ef360ac0d70c46c8cc3260a774917e3928..d8e5002dac11a1e1c591565cc3fdbbea515c90b7 100644 (file)
@@ -181,11 +181,6 @@ config BR2_PACKAGE_LIBEVAS_TIFF
        help
          This enables the loader code that loads tiff files.
 
-config BR2_PACKAGE_LIBEVAS_SVG
-       bool "libevas svg loader"
-       help
-         This enables the loader code that loads svg files.
-
 config BR2_PACKAGE_LIBEVAS_XPM
        bool "libevas xpm loader"
        help
index 8e03ba6bf9da541752a4919516773ca9a5d013a1..6e69d7ff83643decff1710710db57287dd1537fc 100644 (file)
@@ -176,12 +176,6 @@ else
 LIBEVAS_CONF_OPT += --disable-image-loader-pmaps
 endif
 
-ifeq ($(BR2_PACKAGE_LIBEVAS_SVG),y)
-LIBEVAS_CONF_OPT += --enable-image-loader-svg
-else
-LIBEVAS_CONF_OPT += --disable-image-loader-svg
-endif
-
 ifeq ($(BR2_PACKAGE_LIBEVAS_TIFF),y)
 LIBEVAS_CONF_OPT += --enable-image-loader-tiff
 LIBEVAS_DEPENDENCIES += tiff