toolchain/toolchain: set TOOLCHAIN_INSTALL_STAGING only once
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 27 Oct 2019 13:37:56 +0000 (14:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 27 Oct 2019 13:56:52 +0000 (14:56 +0100)
Currently, we set TOOLCHAIN_INSTALL_STAGING three times: once
(conditionally) in toolchain.mk, and once each (unconditionally) in
pkg-cmake.mk and pkg-meson.mk.

This is a little bit messy... Set it just once, unconditionally, in
toolchain.mk where it belongs.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-cmake.mk
package/pkg-meson.mk
toolchain/toolchain/toolchain.mk

index b9ce8ff622b4b1a0b7e7070f5911f59d7ccf450d..57bfea9be5aa19ec2f4790854a78f1947b45467b 100644 (file)
@@ -272,4 +272,3 @@ define TOOLCHAIN_CMAKE_INSTALL_FILES
 endef
 
 TOOLCHAIN_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_CMAKE_INSTALL_FILES
-TOOLCHAIN_INSTALL_STAGING = YES
index 21895654403111981925f3dd9e2191f6236b3136..b11bc3a7c0d6850caa03b3b85204e2a5b032d028 100644 (file)
@@ -206,4 +206,3 @@ define PKG_MESON_INSTALL_CROSS_CONF
 endef
 
 TOOLCHAIN_POST_INSTALL_STAGING_HOOKS += HOST_MESON_INSTALL_CROSS_CONF
-TOOLCHAIN_INSTALL_STAGING = YES
index 17fb62147e8d27d11fcd57c2838f44734780049d..0afb12c036bf1d2b4e7c6a44b6b1ca811557e183 100644 (file)
@@ -11,6 +11,7 @@ TOOLCHAIN_DEPENDENCIES += toolchain-external
 endif
 
 TOOLCHAIN_ADD_TOOLCHAIN_DEPENDENCY = NO
+TOOLCHAIN_INSTALL_STAGING = YES
 
 # Apply a hack that Rick Felker suggested[1] to avoid conflicts between libc
 # headers and kernel headers. This is needed for kernel headers older than
@@ -34,7 +35,6 @@ define TOOLCHAIN_MUSL_KERNEL_HEADERS_COMPATIBILITY_HACK
                $(STAGING_DIR)/usr/include/linux/libc-compat.h
 endef
 TOOLCHAIN_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_MUSL_KERNEL_HEADERS_COMPATIBILITY_HACK
-TOOLCHAIN_INSTALL_STAGING = YES
 endif
 
 # Install default nsswitch.conf file if the skeleton doesn't provide it