libdnet: fix python module build
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Jun 2011 22:01:34 +0000 (00:01 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Jun 2011 22:01:34 +0000 (00:01 +0200)
Ensure the correct compiler/linker flags are used.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libdnet/libdnet-002-python-makefile.patch
package/libdnet/libdnet.mk

index 4c8729ddcd55a8a47cfc4a3a5e0be44084402c43..fb41e43e351107dfe6e8dbc24e50da7762f827b9 100644 (file)
@@ -1,10 +1,16 @@
---- a/python/Makefile.am       2006-01-15 18:08:23.000000000 +1100
-+++ b/python/Makefile.am       2008-09-04 15:25:52.000000000 +1000
+---
+ python/Makefile.am |    1 +
+ 1 file changed, 1 insertion(+)
+
+Index: libdnet-1.11/python/Makefile.am
+===================================================================
+--- libdnet-1.11.orig/python/Makefile.am
++++ libdnet-1.11/python/Makefile.am
 @@ -11,6 +11,7 @@
        pyrexc $(srcdir)/dnet.pyx
  
  python-build: $(srcdir)/dnet.c
-+      CC="$(CC)" LDSHARED="$(CC) -shared" $(PYTHON) setup.py build_ext -I$(PYINCDIR)
++      CC="$(CC)" LDSHARED="$(CC) -shared" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" $(PYTHON) setup.py build_ext -I$(PYINCDIR) -L$(PYLIBDIR)
        $(PYTHON) setup.py build
        touch python-build
  
index 649db31286e043ab0fe8da1bc7a941e4c050ffbf..ae4c9ff16d5a42f9cf83d875400770092acb7f22 100644 (file)
@@ -17,7 +17,7 @@ LIBDNET_CONF_OPT = \
 ifneq ($(BR2_PACKAGE_LIBDNET_PYTHON),)
 LIBDNET_DEPENDENCIES = python
 LIBDNET_CONF_OPT += --with-python
-LIBDNET_MAKE_OPT = PYTHON=python$(PYTHON_VERSION_MAJOR) PYINCDIR=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
+LIBDNET_MAKE_OPT = PYINCDIR=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR) PYLIBDIR=$(STAGING_DIR)/usr/lib
 LIBDNET_INSTALL_TARGET_OPT = $(LIBDNET_MAKE_OPT) DESTDIR=$(TARGET_DIR) INSTALL_STRIP_FLAG=-s install-exec
 LIBDNET_INSTALL_STAGING_OPT = $(LIBDNET_MAKE_OPT) DESTDIR=$(STAGING_DIR) install
 endif