toolchain/external-toolchain/ext-tool.mk: Support non sysroot-able toolchains
authorDaniel Laird <danieljlaird@hotmail.com>
Mon, 12 Jan 2009 12:54:30 +0000 (12:54 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Mon, 12 Jan 2009 12:54:30 +0000 (12:54 -0000)
Only copy the sysroot files if the toolchain was built with sysroot support.

Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
toolchain/external-toolchain/ext-tool.mk

index 8ff4722f37cdf806a4580216dd0f49beac5e5b58..1c9197b95f7f27edf0a1950465139271db2ea256 100644 (file)
@@ -46,8 +46,8 @@ copy_toolchain_lib_root = \
 
 copy_toolchain_sysroot = \
        SYSROOT_DIR=`$(TARGET_CC) -v 2>&1 | grep ^Configured | tr " " "\n" | grep -- "--with-sysroot" | cut -f2 -d=`; \
-       cp -a $${SYSROOT_DIR}/* $(STAGING_DIR)/ ; \
-       find $(STAGING_DIR) -type d | xargs chmod 755
+       if [ -n "$${SYSROOT_DIR}" ]; then cp -a $${SYSROOT_DIR}/* $(STAGING_DIR)/ ; \
+       find $(STAGING_DIR) -type d | xargs chmod 755; fi
 
 uclibc: dependencies $(TARGET_DIR)/lib/$(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIB_C)))
 
@@ -59,4 +59,4 @@ $(TARGET_DIR)/lib/$(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIB_C))):
        for libs in $(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIBS))); do \
                $(call copy_toolchain_lib_root, $$libs, /lib, $(BR2_TOOLCHAIN_EXTERNAL_STRIP)); \
        done
-       $(call copy_toolchain_sysroot)
\ No newline at end of file
+       $(call copy_toolchain_sysroot)