efibootmgr: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:45:53 +0000 (22:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:25 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

The BR2_USE_WCHAR dependency was needed for gettext, now that we no
longer need gettext, we can also get rid of this dependency.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efibootmgr/Config.in
package/efibootmgr/efibootmgr.mk

index 57874fc426f59cf0bac7f6b3c7747abe89a39320..1096b9d729cf4868c2b8a5f2d4a130c354096968 100644 (file)
@@ -6,8 +6,6 @@ config BR2_PACKAGE_EFIBOOTMGR
        depends on !BR2_TOOLCHAIN_USES_MUSL # efivar
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # efivar
        depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS
-       depends on BR2_USE_WCHAR # gettext
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
        select BR2_PACKAGE_EFIVAR
        help
          A Linux user-space application to modify the Intel Extensible
@@ -17,11 +15,10 @@ config BR2_PACKAGE_EFIBOOTMGR
 
          https://github.com/rhinstaller/efibootmgr
 
-comment "efibootmgr needs a glibc or uClibc toolchain w/ wchar, dynamic library, headers >= 3.12, gcc >= 4.9"
+comment "efibootmgr needs a glibc or uClibc toolchain w/ dynamic library, headers >= 3.12, gcc >= 4.9"
        depends on BR2_PACKAGE_EFIVAR_ARCH_SUPPORTS
        depends on BR2_STATIC_LIBS || \
                !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12 || \
                BR2_TOOLCHAIN_USES_MUSL || \
-               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
-               !BR2_USE_WCHAR
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
        depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS
index 094dd2896942d960eb8335b8187fc40702204af5..b32d9cbcfdb761ea10c4c4eb15429974ecf8f4ac 100644 (file)
@@ -8,8 +8,8 @@ EFIBOOTMGR_VERSION = 14
 EFIBOOTMGR_SITE = $(call github,rhinstaller,efibootmgr,$(EFIBOOTMGR_VERSION))
 EFIBOOTMGR_LICENSE = GPL-2.0+
 EFIBOOTMGR_LICENSE_FILES = COPYING
-EFIBOOTMGR_DEPENDENCIES = efivar $(if $(BR2_NEEDS_GETTEXT),gettext)
-EFIBOOTMGR_LDFLAGS = $(TARGET_LDFLAGS) $(if $(BR2_NEEDS_GETTEXT),-lintl)
+EFIBOOTMGR_DEPENDENCIES = efivar $(TARGET_NLS_DEPENDENCIES)
+EFIBOOTMGR_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
 
 define EFIBOOTMSR_PATCH_HEADER_PATH
        $(SED) 's,-I/,-I$(STAGING_DIR)/,' $(@D)/Makefile