blackbox: merge patch and fix linkage problem
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Tue, 17 Dec 2013 16:14:44 +0000 (16:14 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 17 Dec 2013 19:34:54 +0000 (20:34 +0100)
-Merge the current blackbox-0.70.1-configure.patch to a new one named
blackbox-001-Fix-configure-ac.patch that will patch configure.ac instead
and also will add -lpthreads to LIBS to fix a linkage problem.
-Force autoreconf to generate the new configure script using the new
patched configure.ac file.

Fixes:

   http://autobuild.buildroot.net/results/a97/a979cc079706be2012fb4b6c72894aca636adfb6/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/blackbox/blackbox-0.70.1-configure.patch [deleted file]
package/blackbox/blackbox-001-Fix-configure-ac.patch [new file with mode: 0644]
package/blackbox/blackbox.mk

diff --git a/package/blackbox/blackbox-0.70.1-configure.patch b/package/blackbox/blackbox-0.70.1-configure.patch
deleted file mode 100644 (file)
index 3606f97..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/configure        2005-11-03 03:27:16.000000000 -0500
-+++ b/configure        2008-02-02 23:25:25.000000000 -0500
-@@ -1980,12 +1980,6 @@ am__tar='${AMTAR} chof - "$$tardir"'; am
- test "x$prefix" = "xNONE" && prefix="$ac_default_prefix"
--CPPFLAGS="$CPPFLAGS -I$prefix/include"
--LDFLAGS="$LDFLAGS -L$prefix/lib"
--if test "x$prefix" != "x/usr/local"; then
--  CPPFLAGS="$CPPFLAGS -I/usr/local/include"
--  LDFLAGS="$LDFLAGS -L/usr/local/lib"
--fi
- ac_ext=c
- ac_cpp='$CPP $CPPFLAGS'
diff --git a/package/blackbox/blackbox-001-Fix-configure-ac.patch b/package/blackbox/blackbox-001-Fix-configure-ac.patch
new file mode 100644 (file)
index 0000000..1804473
--- /dev/null
@@ -0,0 +1,34 @@
+blackbox: merge existing patch and fix lpthread
+
+Merge the current configure patch into this one so it will patch 
+configure.ac instead. Also add pthread to libs to fix a linkage problem.
+
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+--- blackbox-0.70.1/configure.ac.orig  2013-12-17 11:02:38.799055141 +0000
++++ blackbox-0.70.1/configure.ac       2013-12-17 11:09:08.421204545 +0000
+@@ -8,14 +8,6 @@ AC_CONFIG_SRCDIR([src/blackbox.cc])
+ dnl Determine default prefix
+ test "x$prefix" = "xNONE" && prefix="$ac_default_prefix"
+-dnl Look in the most logical places for external libraries
+-CPPFLAGS="$CPPFLAGS -I$prefix/include"
+-LDFLAGS="$LDFLAGS -L$prefix/lib"
+-if test "x$prefix" != "x/usr/local"; then
+-  CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+-  LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-fi
+-
+ dnl Locate required external software
+ AC_PROG_CC
+@@ -128,6 +120,10 @@ int main(int, char **)
+                   [AC_MSG_RESULT([no])]
+                  )
++dnl required pthread
++AC_CHECK_LIB([pthread],
++           [pthread_cancel],
++           [LIBS="$LIBS -lpthread"])
+ dnl needed for some X11 libs
+ AC_CHECK_LIB([nsl],
+              [t_open],
index 09d15f1d3fc84ff37d5c602049a08075bdc8e94e..ce8f06ea23224a2220f8e248748fd61743c7c39c 100644 (file)
@@ -17,4 +17,6 @@ ifneq ($(BR2_ENABLE_LOCALE),y)
 BLACKBOX_DEPENDENCIES += libiconv
 endif
 
+BLACKBOX_AUTORECONF = YES
+
 $(eval $(autotools-package))