Fix some soft float make variables.
authorManuel Novoa III <mjn3@codepoet.org>
Fri, 21 Nov 2003 02:28:21 +0000 (02:28 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Fri, 21 Nov 2003 02:28:21 +0000 (02:28 -0000)
Makefile

index a4cda2b0f13d80ed5e174dc7b7c61328dbafd82f..19bb5eb91c6d6ca7a6803df0b3cdc3134126b78c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -199,15 +199,13 @@ TARGETS+=ext2root
 # what you are doing.
 #
 #############################################################
-ifeq ("$(strip $(TARGET_SOFT_FLOAT))","")
-ARCH_FPU_SUFFIX:=
-else
-ARCH_FPU_SUFFIX:=_nofpu
-endif
 
 ifeq ($(SOFT_FLOAT),true)
 SOFT_FLOAT_CONFIG_OPTION=--without-float
 TARGET_SOFT_FLOAT=-msoft-float
+ARCH_FPU_SUFFIX:=_nofpu
+else
+ARCH_FPU_SUFFIX:=
 endif
 
 ifeq ($(ENABLE_LOCALE),true)