linux-firmware: fail build for missing file
authorRicardo Martincoski <ricardo.martincoski@gmail.com>
Sun, 14 Jan 2018 23:41:19 +0000 (21:41 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 15 Jan 2018 20:03:28 +0000 (21:03 +0100)
When a file is listed to be installed but is missing from the package
source currently the first tar command exits with error code but it is
ignored and the build succeeds.
This issue by itself is minor because those listed files that are
present in the package source get installed to the target.
But the code is currently error prone, e.g. to a typo in the file list.

Fix this by first creating a tarball in the build directory and then
installing it, instead of using a pipe between the two tar invocations.
Also use && between the commands, so the first command that exits with
error code fails the build.
Since the two tar invocations remain in use, the desired behavior
remains the same:
 - list of files can contain *;
 - list of files can contain file inside path, and the path is then
   replicated in the target;
 - symlinks are not followed but are installed.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Cc: Fabio Estevam <festevam@gmail.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Peter Seiderer <ps.report@gmx.net>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Yegor Yefremov <yegorslists@googlemail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linux-firmware/linux-firmware.mk

index cf79e5603d6a4127afd1a9a0f498a9152955c6cd..03704d80b221b38513d7da3404b6bcc3cf2a8485 100644 (file)
@@ -443,9 +443,9 @@ endif
 
 ifneq ($(LINUX_FIRMWARE_FILES),)
 define LINUX_FIRMWARE_INSTALL_FILES
-       cd $(@D) ; \
-       $(TAR) c $(sort $(LINUX_FIRMWARE_FILES)) | \
-               $(TAR) x -C $(TARGET_DIR)/lib/firmware
+       cd $(@D) && \
+               $(TAR) cf install.tar $(sort $(LINUX_FIRMWARE_FILES)) && \
+               $(TAR) xf install.tar -C $(TARGET_DIR)/lib/firmware
 endef
 endif