php: fix runtime error on big endian
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 23 Oct 2013 22:44:13 +0000 (00:44 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 23 Oct 2013 22:44:13 +0000 (00:44 +0200)
Fixes #6566

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/php/php.mk

index 92665b46b3f08d190fef3dcf1dda4a3e161c4e49..e310bd6052a216b9d88c06ca7a853f550afd84f5 100644 (file)
@@ -19,6 +19,11 @@ PHP_CONF_OPT =  --mandir=/usr/share/man \
                --with-config-file-path=/etc \
                --localstatedir=/var \
                --disable-rpath
+ifeq ($(BR2_ENDIAN),"BIG")
+PHP_CONF_ENV = ac_cv_c_bigendian_php=yes
+else
+PHP_CONF_ENV = ac_cv_c_bigendian_php=no
+endif
 PHP_CONFIG_SCRIPTS = php-config
 
 PHP_CFLAGS = $(TARGET_CFLAGS)