xserver_xorg-server: fix dbus/udev configure problem
authorSimon Dawson <spdawson@gmail.com>
Sun, 23 Sep 2012 02:18:20 +0000 (02:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 23 Sep 2012 18:53:30 +0000 (20:53 +0200)
If both the dbus and udev packages are selected, then the configure step
for the xserver_xorg-server package fails as follows.

  configure: error: Hotplugging through both libudev and dbus/hal not allowed

The configure script no longer allows both the --enable-config-dbus
and --enable-config-udev options to be specified.

This patch changes the xserver_xorg-server makefile to use udev in preference
to dbus, when both are available.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index a19122d4a55a11b645a8ed6cb94737d949c4d203..8018a890731cae66ad906b727f54ee9eaf7edb55 100644 (file)
@@ -104,16 +104,14 @@ XSERVER_XORG_SERVER_DEPENDENCIES += tslib
 XSERVER_XORG_SERVER_CONF_OPT += --enable-tslib LDFLAGS="-lts"
 endif
 
+ifeq ($(BR2_PACKAGE_UDEV),y)
+XSERVER_XORG_SERVER_DEPENDENCIES += udev
+XSERVER_XORG_SERVER_CONF_OPT += --enable-config-udev
+else
 ifeq ($(BR2_PACKAGE_DBUS),y)
 XSERVER_XORG_SERVER_DEPENDENCIES += dbus
 XSERVER_XORG_SERVER_CONF_OPT += --enable-config-dbus
 endif
-
-ifeq ($(BR2_PACKAGE_UDEV),y)
-XSERVER_XORG_SERVER_CONF_OPT += --enable-config-udev
-XSERVER_XORG_SERVER_DEPENDENCIES += udev
-else
-XSERVER_XORG_SERVER_CONF_OPT += --disable-config-udev
 endif
 
 ifeq ($(BR2_PACKAGE_FREETYPE),y)