package/shairport-sync: add dbus option
authorJörg Krause <joerg.krause@embedded.rocks>
Tue, 3 Dec 2019 10:53:40 +0000 (11:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Dec 2019 22:17:23 +0000 (23:17 +0100)
Shairport Sync added DBus support in version 3.2.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/shairport-sync/Config.in
package/shairport-sync/shairport-sync.mk

index 87f38a940da2bbde2110e43e9a9a650b34c90183..750767e5675ed93ff234eda8d13e971d891ab9f1 100644 (file)
@@ -26,6 +26,20 @@ config BR2_PACKAGE_SHAIRPORT_SYNC_CONVOLUTION
        help
          Enable audio DSP convolution support.
 
+config BR2_PACKAGE_SHAIRPORT_SYNC_DBUS
+       bool "dbus support"
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       select BR2_PACKAGE_LIBGLIB2
+       help
+         Enable support for support for the MPRIS and native
+         Shairport Sync D-Bus interface.
+
+comment "shairport-sync dbus support needs a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+
 config BR2_PACKAGE_SHAIRPORT_SYNC_LIBSOXR
        bool "libsoxr support"
        select BR2_PACKAGE_LIBSOXR
index 1ca56e9f0afb532cca2a3f65d432e8a281d5794d..a20570f9158d20c365672065f6e1765fdab11562 100644 (file)
@@ -56,6 +56,11 @@ SHAIRPORT_SYNC_DEPENDENCIES += libsndfile
 SHAIRPORT_SYNC_CONF_OPTS += --with-convolution
 endif
 
+ifeq ($(BR2_PACKAGE_SHAIRPORT_SYNC_DBUS),y)
+SHAIRPORT_SYNC_DEPENDENCIES += libglib2
+SHAIRPORT_SYNC_CONF_OPTS += --with-dbus-interface --with-mpris-interface
+endif
+
 ifeq ($(BR2_PACKAGE_SHAIRPORT_SYNC_LIBSOXR),y)
 SHAIRPORT_SYNC_DEPENDENCIES += libsoxr
 SHAIRPORT_SYNC_CONF_OPTS += --with-soxr