gdb: fix build of host-gdb 7.4
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 19 May 2014 22:07:18 +0000 (00:07 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 19 May 2014 22:30:12 +0000 (00:30 +0200)
The build of host-gdb 7.4 fails due to some texinfo issue. To avoid
that, use the same trick as is used for the target variant of gdb:
tell gdb that makeinfo is missing.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/gdb.mk

index 678c17cfd9a48657f9e4f624003ba8c5024872bc..c3fca40c2ba7e9b7df22be82dd72878503db4f5b 100644 (file)
@@ -50,6 +50,9 @@ GDB_PRE_PATCH_HOOKS += GDB_XTENSA_PRE_PATCH
 HOST_GDB_PRE_PATCH_HOOKS += GDB_XTENSA_PRE_PATCH
 endif
 
+HOST_GDB_CONF_ENV = \
+       ac_cv_prog_MAKEINFO=missing
+
 GDB_CONF_ENV = \
        ac_cv_prog_MAKEINFO=missing \
        ac_cv_type_uintptr_t=yes \