uboot: remove deprecated BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 11 Mar 2016 14:32:24 +0000 (11:32 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 15 Mar 2016 21:47:47 +0000 (22:47 +0100)
It's been deprecated for a year now so remove it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
boot/uboot/Config.in
boot/uboot/uboot.mk

index 8a067dd483278a7d1d03cf2ef712c6c6dcae6d38..8cae3b259445359b0c58edc3aa24640c53c995b2 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.05"
 
+config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
+       bool "uboot custom patch dir removed"
+       select BR2_LEGACY
+       help
+         The uboot custom patch directory option has been removed. Use
+         the improved BR2_TARGET_UBOOT_PATCH option instead.
+
 config BR2_PACKAGE_XDRIVER_XF86_INPUT_VOID
        bool "xf86-input-void removed"
        select BR2_LEGACY
index f1d3d2adc51e8ca84b0beb3b1f9fb1e493d7f8cf..0e79734d2f6a7b43c37f5e27829e37361ad91ed7 100644 (file)
@@ -90,18 +90,6 @@ config BR2_TARGET_UBOOT_VERSION
        default BR2_TARGET_UBOOT_CUSTOM_REPO_VERSION \
                if BR2_TARGET_UBOOT_CUSTOM_GIT || BR2_TARGET_UBOOT_CUSTOM_HG
 
-config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
-       string "custom patch dir"
-       depends on BR2_DEPRECATED_SINCE_2015_05
-       help
-         If your board requires custom patches, add the path to the
-         directory containing the patches here. The patches must be
-         named uboot-<something>.patch.
-
-         Most users may leave this empty
-
-         NOTE: Use BR2_TARGET_UBOOT_PATCH instead.
-
 config BR2_TARGET_UBOOT_PATCH
        string "Custom U-Boot patches"
        help
index d539b3123aef61e272e3313036cc4f21562c5351..f9a3ff8280a34a7c2b5c4b0f6c0dc8f15bd5c6b0 100644 (file)
@@ -100,16 +100,6 @@ endef
 UBOOT_POST_EXTRACT_HOOKS += UBOOT_COPY_OLD_LICENSE_FILE
 UBOOT_POST_RSYNC_HOOKS += UBOOT_COPY_OLD_LICENSE_FILE
 
-# Prior to Buildroot 2015.05, only patch directories were supported. New
-# configurations use BR2_TARGET_UBOOT_PATCH instead.
-ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
-define UBOOT_APPLY_CUSTOM_PATCHES
-       $(APPLY_PATCHES) $(@D) $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR) \*.patch
-endef
-
-UBOOT_POST_PATCH_HOOKS += UBOOT_APPLY_CUSTOM_PATCHES
-endif
-
 # Analogous code exists in linux/linux.mk. Basically, the generic
 # package infrastructure handles downloading and applying remote
 # patches. Local patches are handled depending on whether they are