package/apcupsd: disable docs
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 19 Apr 2020 22:40:09 +0000 (16:40 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 Apr 2020 05:43:53 +0000 (07:43 +0200)
We can skip building docs by only running make against subdirs that are
not "doc".

Fixes:
http://autobuild.buildroot.net/results/e65/e65c23c3c1cae9aa9d697323fabf8a6f310fc3ba/build-end.log

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/apcupsd/apcupsd.mk

index e750657236a21dd9aeb83208600faec386ea775d..ff9cc9242fac5751405abdfcd722b6cf747f6243 100644 (file)
@@ -64,4 +64,14 @@ else
 APCUPSD_CONF_OPTS += --disable-usb
 endif
 
+define APCUPSD_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/platforms
+endef
+
+define APCUPSD_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src DESTDIR=$(TARGET_DIR) install
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/platforms DESTDIR=$(TARGET_DIR) install
+endef
+
 $(eval $(autotools-package))