util-linux: Add an option to compile 'nsenter' binary.
authorNicolas Cavallari <nicolas.cavallari@green-communications.fr>
Tue, 23 Dec 2014 10:44:10 +0000 (11:44 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 26 Dec 2014 19:09:34 +0000 (20:09 +0100)
nsenter is a tool to enter the namespace of another process.

[Thomas: add dependency to 3.0 kernel headers, since the setns()
system call was added in Linux 3.0.]

Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/Config.in
package/util-linux/util-linux.mk

index 5dfd050233ee317fe8c8b254f2cbded51fbe4c79..a8dfa1c025b3889cc0d68aaccf66c8a748f16aa3 100644 (file)
@@ -118,6 +118,15 @@ config BR2_PACKAGE_UTIL_LINUX_MESG
        help
          Control write access to your terminal
 
+config BR2_PACKAGE_UTIL_LINUX_NSENTER
+       bool "nsenter"
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
+       help
+         Enter the namespaces of another process.
+
+comment "nsenter needs a toolchain w/ headers >= 3.0"
+       depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
+
 config BR2_PACKAGE_UTIL_LINUX_MOUNT
        bool "mount/umount"
        help
index e06fa9a8c42ccae62cf1efba6bb0bfddf7388681..a530596ea61a4b7900965008ba4e56a3d85d48c0 100644 (file)
@@ -74,6 +74,7 @@ UTIL_LINUX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),--enable-last --enable-login --enable-su --enable-sulogin,--disable-last --disable-login --disable-su --disable-sulogin) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_LOSETUP),--enable-losetup,--disable-losetup) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_MESG),--enable-mesg,--disable-mesg) \
+       $(if $(BR2_PACKAGE_UTIL_LINUX_NSENTER),--enable-nsenter,--disable-nsenter) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_MOUNT),--enable-mount,--disable-mount) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_NEWGRP),--enable-newgrp,--disable-newgrp) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_PARTX),--enable-partx,--disable-partx) \