package/mpd: bump to version 0.19.15
authorJörg Krause <joerg.krause@embedded.rocks>
Sun, 1 May 2016 17:19:49 +0000 (19:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 May 2016 20:21:33 +0000 (22:21 +0200)
Drop patches applied upstream:
 - 0001: notify: Don't use constexpr on Haiku
 - 0002: notify: use "constexpr" only with glibc

Renumber remaining patches.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpd/0001-configure.ac-check-if-libatomic-is-needed.patch [new file with mode: 0644]
package/mpd/0001-notify-Don-t-use-constexpr-on-Haiku.patch [deleted file]
package/mpd/0002-notify-use-constexpr-only-with-glibc.patch [deleted file]
package/mpd/0002-thread-Name-include-stdio.h-for-prctl-as-well.patch [new file with mode: 0644]
package/mpd/0003-configure.ac-check-if-libatomic-is-needed.patch [deleted file]
package/mpd/0004-thread-Name-include-stdio.h-for-prctl-as-well.patch [deleted file]
package/mpd/mpd.hash
package/mpd/mpd.mk

diff --git a/package/mpd/0001-configure.ac-check-if-libatomic-is-needed.patch b/package/mpd/0001-configure.ac-check-if-libatomic-is-needed.patch
new file mode 100644 (file)
index 0000000..a9873a7
--- /dev/null
@@ -0,0 +1,40 @@
+From 8eaf14a17244aaf000b4d19e4fde4a637576939f Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Sun, 7 Feb 2016 21:40:47 +0100
+Subject: [PATCH] configure.ac: check if libatomic is needed
+
+The mpd source code uses the C++11 <atomic> functionality, which
+internally is implemented using the __atomic_*() gcc built-ins. On
+certain architectures, the __atomic_*() built-ins are implemented in
+the libatomic library that comes with the rest of the gcc runtime. Due
+to this, code using <atomic> might need to link against libatomic,
+otherwise one hits build issues such as:
+
+GlobalEvents.cxx:(.text._ZN12GlobalEvents4EmitENS_5EventE+0x14): undefined reference to `__atomic_fetch_or_4'
+
+on an architecture like SPARC.
+
+To solve this, a configure.ac check is added to know if we need to
+link against libatomic or not.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 107b45a..8e6fab7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -233,6 +233,8 @@ if test x$have_pthread_setname_np = xyes; then
+       AC_DEFINE(HAVE_PTHREAD_SETNAME_NP, 1, [Is pthread_setname_np() available?])
+ fi
++AC_SEARCH_LIBS([__atomic_load_4], [atomic])
++
+ dnl ---------------------------------------------------------------------------
+ dnl Event loop selection
+ dnl ---------------------------------------------------------------------------
+-- 
+2.6.4
+
diff --git a/package/mpd/0001-notify-Don-t-use-constexpr-on-Haiku.patch b/package/mpd/0001-notify-Don-t-use-constexpr-on-Haiku.patch
deleted file mode 100644 (file)
index 2685578..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From f7d5081b727f69ae3a894a4a3310670a5d9ab077 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Fran=C3=A7ois=20Revol?= <revol@free.fr>
-Date: Thu, 17 Sep 2015 22:18:10 +0200
-Subject: [PATCH] notify: Don't use constexpr on Haiku
-
-[Thomas: taken from upstream commit bf73d0f9051fd5740c22bf6e5114ceb4535d548f.]
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- src/notify.hxx | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/notify.hxx b/src/notify.hxx
-index 3e62a01..1ee413f 100644
---- a/src/notify.hxx
-+++ b/src/notify.hxx
-@@ -28,7 +28,8 @@ struct notify {
-       Cond cond;
-       bool pending;
--#if !defined(WIN32) && !defined(__NetBSD__) && !defined(__BIONIC__)
-+#if !defined(WIN32) && !defined(__NetBSD__) && !defined(__BIONIC__) && \
-+      !defined(__HAIKU__)
-       constexpr
- #endif
-       notify():pending(false) {}
--- 
-2.6.4
-
diff --git a/package/mpd/0002-notify-use-constexpr-only-with-glibc.patch b/package/mpd/0002-notify-use-constexpr-only-with-glibc.patch
deleted file mode 100644 (file)
index e50f598..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 09830d448d6299a47fbccf39af6f325be5f2b514 Mon Sep 17 00:00:00 2001
-From: Max Kellermann <max@duempel.org>
-Date: Thu, 17 Sep 2015 22:56:35 +0200
-Subject: [PATCH] notify: use "constexpr" only with glibc
-
-The Mutex and Cond constructors are only "constexpr" with glibc, and
-this is what this #ifdef is about.
-
-[Thomas: taken from upstream commit 459a812a54509ebfd634a3df2998395c9cb5b98f.]
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- src/notify.hxx | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/src/notify.hxx b/src/notify.hxx
-index 1ee413f..c96390b 100644
---- a/src/notify.hxx
-+++ b/src/notify.hxx
-@@ -28,8 +28,7 @@ struct notify {
-       Cond cond;
-       bool pending;
--#if !defined(WIN32) && !defined(__NetBSD__) && !defined(__BIONIC__) && \
--      !defined(__HAIKU__)
-+#ifdef __GLIBC__
-       constexpr
- #endif
-       notify():pending(false) {}
--- 
-2.6.4
-
diff --git a/package/mpd/0002-thread-Name-include-stdio.h-for-prctl-as-well.patch b/package/mpd/0002-thread-Name-include-stdio.h-for-prctl-as-well.patch
new file mode 100644 (file)
index 0000000..1943623
--- /dev/null
@@ -0,0 +1,28 @@
+From a0a9fed68126eb24e04af924c0d46351ff5eeb0f Mon Sep 17 00:00:00 2001
+From: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Date: Mon, 26 Jan 2015 09:55:04 -0300
+Subject: [PATCH] thread/Name: include stdio.h for prctl as well
+
+We're still using snprintf so we need it, otherwise it leads to build
+failure.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+---
+ src/thread/Name.hxx | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/thread/Name.hxx b/src/thread/Name.hxx
+index a99208d..8f9d7d3 100644
+--- a/src/thread/Name.hxx
++++ b/src/thread/Name.hxx
+@@ -25,6 +25,7 @@
+ #  include <pthread.h>
+ #elif defined(HAVE_PRCTL)
+ #  include <sys/prctl.h>
++#  include <stdio.h>
+ #  ifdef PR_SET_NAME
+ #    define HAVE_THREAD_NAME
+ #  endif
+-- 
+2.6.4
+
diff --git a/package/mpd/0003-configure.ac-check-if-libatomic-is-needed.patch b/package/mpd/0003-configure.ac-check-if-libatomic-is-needed.patch
deleted file mode 100644 (file)
index a9873a7..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-From 8eaf14a17244aaf000b4d19e4fde4a637576939f Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Sun, 7 Feb 2016 21:40:47 +0100
-Subject: [PATCH] configure.ac: check if libatomic is needed
-
-The mpd source code uses the C++11 <atomic> functionality, which
-internally is implemented using the __atomic_*() gcc built-ins. On
-certain architectures, the __atomic_*() built-ins are implemented in
-the libatomic library that comes with the rest of the gcc runtime. Due
-to this, code using <atomic> might need to link against libatomic,
-otherwise one hits build issues such as:
-
-GlobalEvents.cxx:(.text._ZN12GlobalEvents4EmitENS_5EventE+0x14): undefined reference to `__atomic_fetch_or_4'
-
-on an architecture like SPARC.
-
-To solve this, a configure.ac check is added to know if we need to
-link against libatomic or not.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- configure.ac | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 107b45a..8e6fab7 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -233,6 +233,8 @@ if test x$have_pthread_setname_np = xyes; then
-       AC_DEFINE(HAVE_PTHREAD_SETNAME_NP, 1, [Is pthread_setname_np() available?])
- fi
-+AC_SEARCH_LIBS([__atomic_load_4], [atomic])
-+
- dnl ---------------------------------------------------------------------------
- dnl Event loop selection
- dnl ---------------------------------------------------------------------------
--- 
-2.6.4
-
diff --git a/package/mpd/0004-thread-Name-include-stdio.h-for-prctl-as-well.patch b/package/mpd/0004-thread-Name-include-stdio.h-for-prctl-as-well.patch
deleted file mode 100644 (file)
index 1943623..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From a0a9fed68126eb24e04af924c0d46351ff5eeb0f Mon Sep 17 00:00:00 2001
-From: Gustavo Zacarias <gustavo@zacarias.com.ar>
-Date: Mon, 26 Jan 2015 09:55:04 -0300
-Subject: [PATCH] thread/Name: include stdio.h for prctl as well
-
-We're still using snprintf so we need it, otherwise it leads to build
-failure.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
----
- src/thread/Name.hxx | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/thread/Name.hxx b/src/thread/Name.hxx
-index a99208d..8f9d7d3 100644
---- a/src/thread/Name.hxx
-+++ b/src/thread/Name.hxx
-@@ -25,6 +25,7 @@
- #  include <pthread.h>
- #elif defined(HAVE_PRCTL)
- #  include <sys/prctl.h>
-+#  include <stdio.h>
- #  ifdef PR_SET_NAME
- #    define HAVE_THREAD_NAME
- #  endif
--- 
-2.6.4
-
index e47cefd53a545d81640db09da4bcccdd6e47ae98..2d35aaeb6294a57fb9472ff0af47f2b767c49367 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated after checking pgp signature
-sha256 2fd23805132e5002a4d24930001a7c7d3aaf55e3bd0cd71af5385895160e99e7        mpd-0.19.14.tar.xz
+sha256  0cb9a223894b038ce966ce6d651d9b3ea3bdc7d7b9bec8d1e9e7e091cbc29b8b  mpd-0.19.15.tar.xz
index 9a1c9572a2e9e594d3ea2c3e655ae413187f677f..6247d15d39b898922ad402fc3e9bed0084fc7080 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 MPD_VERSION_MAJOR = 0.19
-MPD_VERSION = $(MPD_VERSION_MAJOR).14
+MPD_VERSION = $(MPD_VERSION_MAJOR).15
 MPD_SOURCE = mpd-$(MPD_VERSION).tar.xz
 MPD_SITE = http://www.musicpd.org/download/mpd/$(MPD_VERSION_MAJOR)
 MPD_DEPENDENCIES = host-pkgconf boost libglib2