uclibc: install headers after building headers in configure part
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Tue, 30 Sep 2008 07:29:35 +0000 (07:29 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Tue, 30 Sep 2008 07:29:35 +0000 (07:29 -0000)
This patch will run "make headers install_headers" instead of the old "make
headers install_dev". The latter requires a cross compiler available in uClibc
versions > 0.9.29, and the cross compiler is not available at the configuration
time of uClibc.

Spotted and fixed by Bernhard Fischer.

Tested-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
toolchain/uClibc/uclibc.mk

index dba5a96d9026b989faeadee1fe9d6fc8b9cdabfe..e39e157c61e9eaee7de25b71c623a08b5ebac203 100644 (file)
@@ -434,7 +434,7 @@ $(UCLIBC_DIR)/.configured: $(LINUX_HEADERS_DIR)/.configured $(UCLIBC_DIR)/.confi
                DEVEL_PREFIX=/usr/ \
                RUNTIME_PREFIX=$(TOOL_BUILD_DIR)/uClibc_dev/ \
                HOSTCC="$(HOSTCC)" \
-               headers install_dev
+               headers install_headers
        # Install the kernel headers to the first stage gcc include dir
        # if necessary
 ifeq ($(LINUX_HEADERS_IS_KERNEL),y)