pkg-generic: introduce helper function to check for a deprecated variable
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Sat, 27 Sep 2014 19:32:48 +0000 (21:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Oct 2014 16:55:44 +0000 (18:55 +0200)
This patch introduces a helper check-deprecated-variable, that throws an
error when a package defines a deprecated variable. This helps in detecting
transition errors when changing the buildroot infrastructures, and also
helps users that have created packages not part of mainline buildroot.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index 4b6d818bf9de3d2444e62832656c87315f0d8093..a89425f231fb3a5ebe17bbb9622a3b9e354a6b02 100644 (file)
@@ -263,6 +263,21 @@ be selected at a time. Please fix your configuration)
 endif
 endef
 
+################################################################################
+# check-deprecated-variable -- throw an error on deprecated variables
+#
+# argument 1 is the deprecated variable
+# argument 2 is the new variable to use
+#
+# example:
+#   $(eval $(call check-deprecated-variable,FOO_MAKE_OPT,FOO_MAKE_OPTS))
+################################################################################
+define check-deprecated-variable
+ifneq ($$(origin $(1)),undefined)
+$$(error Package error: use $(2) instead of $(1). Please fix your .mk file)
+endif
+endef
+
 ################################################################################
 # inner-generic-package -- generates the make targets needed to build a
 # generic package