rework hotplug with a customized version not dependant on kernel sources
authorEric Andersen <andersen@codepoet.org>
Thu, 10 Aug 2006 20:08:31 +0000 (20:08 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 10 Aug 2006 20:08:31 +0000 (20:08 -0000)
package/hotplug/diethotplug-0.5.tar [new file with mode: 0644]
package/hotplug/hotplug.mk
package/hotplug/hotplug.patch [deleted file]

diff --git a/package/hotplug/diethotplug-0.5.tar b/package/hotplug/diethotplug-0.5.tar
new file mode 100644 (file)
index 0000000..8088670
Binary files /dev/null and b/package/hotplug/diethotplug-0.5.tar differ
index 25fc5cfcbe2cd6bca2edf82009262a3a066ea1b8..e4cb063c96f2961d478fef5f4784a033aeeb67da 100644 (file)
@@ -3,15 +3,13 @@
 # hotplug support
 #
 #############################################################
-HOTPLUG_SOURCE=diethotplug-0.4.tar.gz
+HOTPLUG_SOURCE=package/hotplug/diethotplug-0.5.tar
 HOTPLUG_SITE=http://www.kernel.org/pub/linux/utils/kernel/hotplug/
-HOTPLUG_DIR=$(BUILD_DIR)/diethotplug-0.4
+HOTPLUG_DIR=$(BUILD_DIR)/diethotplug-0.5
+HOTPLUG_CAT=cat
 
-$(DL_DIR)/$(HOTPLUG_SOURCE):
-       $(WGET) -P $(DL_DIR) $(HOTPLUG_SITE)/$(HOTPLUG_SOURCE)
-
-$(HOTPLUG_DIR): $(DL_DIR)/$(HOTPLUG_SOURCE)
-       zcat $(DL_DIR)/$(HOTPLUG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+$(HOTPLUG_DIR): $(HOTPLUG_SOURCE)
+       $(HOTPLUG_CAT) $(HOTPLUG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        toolchain/patch-kernel.sh $(HOTPLUG_DIR) package/hotplug/ hotplug\*.patch
 
 $(HOTPLUG_DIR)/hotplug: $(HOTPLUG_DIR)
diff --git a/package/hotplug/hotplug.patch b/package/hotplug/hotplug.patch
deleted file mode 100644 (file)
index 22c356b..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -urN diethotplug-0.4.orig/pci.c diethotplug-0.4/pci.c
---- diethotplug-0.4.orig/pci.c Wed Jan  9 13:57:29 2002
-+++ diethotplug-0.4/pci.c      Wed Jan 30 22:35:24 2002
-@@ -68,8 +68,8 @@
-               }
-               /* check that the class matches */
--              class_temp = pci_module_map[i].class_mask & pci_class;
--              if (pci_module_map[i].class != class_temp) {
-+              class_temp = (pci_module_map[i].class ^ pci_class) & pci_module_map[i].class_mask; 
-+              if (class_temp != 0) { 
-                       dbg ("class mask check failed %x != %x",
-                            pci_module_map[i].class, class_temp);
-                       continue;
---- diethotplug-0.4/Makefile.orig      Wed Jan  9 14:28:05 2002
-+++ diethotplug-0.4/Makefile   Mon Jul  8 07:29:00 2002
-@@ -135,13 +135,13 @@
- # Rules on how to create the generated header files
- usb_modules.h:
--      perl convert_usb.pl < /lib/modules/$(KERNEL_VERSION)/modules.usbmap > $@
-+      perl convert_usb.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.usbmap > $@
- pci_modules.h:
--      perl convert_pci.pl < /lib/modules/$(KERNEL_VERSION)/modules.pcimap > $@
-+      perl convert_pci.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.pcimap > $@
- ieee1394_modules.h:
--      perl convert_ieee1394.pl < /lib/modules/$(KERNEL_VERSION)/modules.ieee1394map > $@
-+      perl convert_ieee1394.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.ieee1394map > $@
- hotplug_version.h:
-       @echo \#define HOTPLUG_VERSION \"$(VERSION)\" > $@