Make sure libgcc_s.so.1 and friends always gets installed in TARGET_DIR.
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 16 Nov 2006 09:55:20 +0000 (09:55 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 16 Nov 2006 09:55:20 +0000 (09:55 -0000)
Patch by Lars Munch.

toolchain/gcc/gcc-uclibc-3.x.mk

index 4b05fee5f65591f12009f33041e18ed9a97f3f36..258a335bd647fd6ab9ad78a87266db228568a819 100644 (file)
@@ -250,6 +250,9 @@ endif
        #
        # Ok... that's enough of that.
        #
+       touch $(GCC_BUILD_DIR2)/.installed
+
+gcc-target-libs: $(GCC_BUILD_DIR2)/.installed
 ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
        # These are in /lib, so...
        rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
@@ -266,10 +269,9 @@ ifeq ($(BR2_INSTALL_LIBGCJ),y)
        -cp -a $(STAGING_DIR)/usr/lib/security/libgcj.security $(TARGET_DIR)/usr/lib/security/
        -cp -a $(STAGING_DIR)/usr/lib/security/classpath.security $(TARGET_DIR)/usr/lib/security/
 endif
-       touch $(GCC_BUILD_DIR2)/.installed
 
 gcc: uclibc-configured binutils gcc_initial $(LIBFLOAT_TARGET) uclibc \
-       $(GCC_BUILD_DIR2)/.installed $(GCC_TARGETS)
+       $(GCC_BUILD_DIR2)/.installed gcc-target-libs $(GCC_TARGETS)
 
 gcc-source: $(DL_DIR)/$(GCC_SOURCE)