Add x-loader bootloader
authorPhilippe Reynes <tremyfr@yahoo.fr>
Mon, 11 Jul 2011 20:46:13 +0000 (22:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 11 Jul 2011 21:41:29 +0000 (23:41 +0200)
Signed-off-by: Philippe Reynes <tremyfr@yahoo.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
merge xloader
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/Config.in
boot/xloader/Config.in [new file with mode: 0644]
boot/xloader/xloader.mk [new file with mode: 0644]

index 67adae83188d0b754d277e4a94e26fb40fb9fc29..2a97695d57c8b32a3b435ed0806dc98c8b89ffe0 100644 (file)
@@ -6,6 +6,7 @@ source "boot/syslinux/Config.in"
 source "boot/uboot/Config.in"
 source "boot/at91bootstrap/Config.in"
 source "boot/at91dataflashboot/Config.in"
+source "boot/xloader/Config.in"
 
 endmenu
 
diff --git a/boot/xloader/Config.in b/boot/xloader/Config.in
new file mode 100644 (file)
index 0000000..d295b45
--- /dev/null
@@ -0,0 +1,15 @@
+menuconfig BR2_TARGET_XLOADER
+       bool "X-loader"
+       depends on BR2_cortex_a8 || BR2_cortex_a9
+       help
+         The x-loader bootloader. It is mainly used on OMAP-based
+         platforms.
+
+if BR2_TARGET_XLOADER
+config BR2_TARGET_XLOADER_BOARDNAME
+       string "x-loader board name"
+       help
+         One of x-loader supported boards to be built.
+         This will be suffixed with _config to meet x-loader
+         standard naming.
+endif
diff --git a/boot/xloader/xloader.mk b/boot/xloader/xloader.mk
new file mode 100644 (file)
index 0000000..8d8cce3
--- /dev/null
@@ -0,0 +1,37 @@
+#############################################################
+#
+# x-loader
+#
+#############################################################
+XLOADER_VERSION    = 6f3a26101303051e0f91b6213735b68ce804e94e
+XLOADER_SITE       = git://gitorious.org/x-loader/x-loader.git
+XLOADER_BOARD_NAME = $(call qstrip,$(BR2_TARGET_XLOADER_BOARDNAME))
+
+XLOADER_INSTALL_IMAGES = YES
+
+define XLOADER_BUILD_CMDS
+       $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D) $(XLOADER_BOARD_NAME)_config
+       $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D) all
+       $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D) ift
+endef
+
+define XLOADER_INSTALL_IMAGES_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/MLO $(BINARIES_DIR)/
+endef
+
+$(eval $(call GENTARGETS,boot,xloader))
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(BR2_TARGET_XLOADER),y)
+# we NEED a board name unless we're at make source
+ifeq ($(filter source,$(MAKECMDGOALS)),)
+ifeq ($(XLOADER_BOARD_NAME),)
+$(error NO x-loader board name set. Check your BR2_BOOT_XLOADER_BOARDNAME setting)
+endif
+endif
+
+endif