package/elfutils: fix host build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 1 Oct 2020 05:25:50 +0000 (07:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 1 Oct 2020 08:48:47 +0000 (10:48 +0200)
Commit 52c5c6050c5359288ca48c85024aebd169fab258 disabled debuginfod on
target but not on host resulting in the following build failure:

configure: error: dependencies not found, use --disable-libdebuginfod to disable or --enable-libdebuginfod=dummy to build a (bootstrap) dummy library.

Fixes:
 - http://autobuild.buildroot.org/results/97713c7e281313826067af559337832f22c3cb09

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/elfutils/elfutils.mk

index 3615a16cd073938c2e832af67425d8eaf66788d1..28f86c2fab52a09f3d9b34f38fed294a1d450803 100644 (file)
@@ -50,6 +50,7 @@ endif
 
 # disable for now, needs "distro" support
 ELFUTILS_CONF_OPTS += --disable-libdebuginfod --disable-debuginfod
+HOST_ELFUTILS_CONF_OPTS += --disable-libdebuginfod --disable-debuginfod
 
 ELFUTILS_CONF_ENV += \
        LDFLAGS="$(ELFUTILS_LDFLAGS)"