libiconv: fixup library permissions
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 18 Sep 2013 13:38:02 +0000 (10:38 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Sep 2013 14:57:14 +0000 (16:57 +0200)
libiconv.so* and libcharset.so* are installed without +x permissions
thus preventing stripping. Fix it up in the post install target hooks.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libiconv/libiconv.mk

index d6a1d6f498bf5238c3834f6362c2f4075c801ae9..aa6d6de8b623f8266b561397a74d752be451a3ee 100644 (file)
@@ -21,6 +21,14 @@ endef
 LIBICONV_POST_INSTALL_TARGET_HOOKS += LIBICONV_TARGET_REMOVE_PRELOADABLE_LIBS
 LIBICONV_POST_INSTALL_STAGING_HOOKS += LIBICONV_STAGING_REMOVE_PRELOADABLE_LIBS
 
+# Library lacks +x so strip skips it
+define LIBICONV_FIX_LIBRARY_MODE
+       -chmod +x $(TARGET_DIR)/usr/lib/libcharset.so*
+       -chmod +x $(TARGET_DIR)/usr/lib/libiconv.so*
+endef
+
+LIBICONV_POST_INSTALL_TARGET_HOOKS += LIBICONV_FIX_LIBRARY_MODE
+
 $(eval $(autotools-package))
 
 # Configurations where the toolchain supports locales and the libiconv