toolchain-external: bump version of Linaro ARM toolchain
authorRomain Naour <romain.naour@gmail.com>
Sat, 24 Sep 2016 09:37:51 +0000 (11:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 25 Sep 2016 20:00:38 +0000 (22:00 +0200)
The gdb version is 7.11.1 not 7.10 as stated in the link below [1].
See the manifest to check the version really used [2].

Tested with Qemu 2.4.1 and qemu_arm_vexpress_defconfig.

[1] https://releases.linaro.org/components/toolchain/binaries/5.3-2016.05
[2] https://releases.linaro.org/components/toolchain/binaries/5.3-2016.05/arm-linux-gnueabihf/gcc-linaro-5.3.1-2016.05-linux-manifest.txt

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/toolchain-external.hash
toolchain/toolchain-external/toolchain-external.mk

index c3822edad5ea02612f18b65bb37dd971f0f98d52..ab1ccd51875d5ee1effbf1fe1e18a311d2feaaad 100644 (file)
@@ -39,7 +39,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
 
 # See the note above.
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
-       bool "Linaro ARM 2016.02"
+       bool "Linaro ARM 2016.05"
        depends on BR2_arm
        depends on BR2_ARM_CPU_ARMV7A
        depends on BR2_HOSTARCH = "x86_64"
@@ -54,8 +54,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
        select BR2_TOOLCHAIN_HAS_FORTRAN
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2016.02 (based on gcc 5.3), Linaro GDB 2016.02 (based on
-         GDB 7.10), glibc 2.21, Binutils 2015.10 (based on 2.25). It
+         GCC 2016.05 (based on gcc 5.3.1), Linaro GDB 2016.05 (based on
+         GDB 7.11.1), glibc 2.21, Binutils 2016.05 (based on 2.25). It
          generates code that runs on all Cortex-A profile devices,
          but tuned for the Cortex-A9. The code generated is Thumb 2,
          with the hard floating point calling convention, and uses
index 9d74cb780db5e8612ddacface7c2d2adf441217d..90687416031ade231dbb6cd94621d1b573367aae 100644 (file)
@@ -37,7 +37,7 @@ sha256 25fbf0513ad7322b15cbaae964cafadcbb4c939f2708f57f40b8f9f2d601122b  arago-t
 # ARM and Aarch64 toolchains from Linaro
 sha256 0cffac0caea0eb3c8bdddfa14be011ce366680f40aeddbefc7cf23cb6d4f1891  gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_linux.tar.xz
 sha256 eafeb3a5247e9ce31aa35d812e296fba5d5f1443e106d9bef9e38d3ee3ade006  gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_src.tar.bz2
-sha256 dd66f07662e1f3b555eaa0d076f133b6db702ab0b9ab18f7dfc91a23eab653c5  gcc-linaro-5.3-2016.02-x86_64_arm-linux-gnueabihf.tar.xz
+sha256 987941c9fffdf56ffcbe90e8984673c16648c477b537fcf43add22fa62f161cd  gcc-linaro-5.3.1-2016.05-x86_64_arm-linux-gnueabihf.tar.xz
 sha256 4bc9d86390f8fa67a693ba4768ba5b12faaf7dd37c706c05ccd9321e765226e4  gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_linux.tar.xz
 sha256 bf5d3111dad5aa9aef0e955875fb7fc9e918cb24519af7014dd67a9e581a49b1  gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_src.tar.bz2
 sha256 f488caf46680b0c0a16b66b43fbfd157e3d6389df18e957983132e89529a9804  gcc-linaro-5.3-2016.02-x86_64_armeb-linux-gnueabihf.tar.xz
index ad258b86be43542342257efbfbe07455a2a9405b..caa1253316365529111ae69c7eafeaeab3206b83 100644 (file)
@@ -335,8 +335,8 @@ TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_linux.tar
 TOOLCHAIN_EXTERNAL_ACTUAL_SOURCE_TARBALL = gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_src.tar.bz2
 TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_LINARO_SYMLINK
 else
-TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/components/toolchain/binaries/5.3-2016.02/arm-linux-gnueabihf
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-5.3-2016.02-x86_64_arm-linux-gnueabihf.tar.xz
+TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/components/toolchain/binaries/5.3-2016.05/arm-linux-gnueabihf
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-5.3.1-2016.05-x86_64_arm-linux-gnueabihf.tar.xz
 endif
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB),y)
 ifeq ($(HOSTARCH),x86)