Make some more things compile
authorEric Andersen <andersen@codepoet.org>
Thu, 4 Sep 2003 23:48:03 +0000 (23:48 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 4 Sep 2003 23:48:03 +0000 (23:48 -0000)
make/bridge.mk
make/iptables.mk

index b26726a3eedf887e17620af578599c878455dd09..0ecfa9c217d1a58bf9add5f416738d4c1dd9587b 100644 (file)
@@ -19,14 +19,27 @@ $(BRIDGE_BUILD_DIR)/.unpacked: $(DL_DIR)/$(BRIDGE_SOURCE)
 $(BRIDGE_BUILD_DIR)/.configured: $(BRIDGE_BUILD_DIR)/.unpacked
        (cd $(BRIDGE_BUILD_DIR); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
-                ./configure \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               $(DISABLE_NLS) \
                --with-linux-headers=$(BUILD_DIR)/linux \
        );
-       
        touch  $(BRIDGE_BUILD_DIR)/.configured
 
 $(BRIDGE_BUILD_DIR)/brctl/brctl: $(BRIDGE_BUILD_DIR)/.configured
-       $(MAKE) -C $(BRIDGE_BUILD_DIR) CC=$(TARGET_CC)
+       $(MAKE) -C $(BRIDGE_BUILD_DIR)
 
 $(TARGET_DIR)/sbin/brctl: $(BRIDGE_BUILD_DIR)/brctl/brctl
        cp -af $(BRIDGE_BUILD_DIR)/brctl/brctl $(TARGET_DIR)/sbin/
index 118a316e840af8ffcb89365886bf11cb15d2f1b2..df434125023aed61ba3137b9d7d054d569c470c2 100644 (file)
@@ -3,7 +3,7 @@
 # iptables
 #
 #############################################################
-IPTABLES_SOURCE_URL=ftp://ftp.netfilter.org/pub/iptables
+IPTABLES_SOURCE_URL=http://www.netfilter.org/files
 IPTABLES_SOURCE=iptables-1.2.8.tar.bz2
 IPTABLES_BUILD_DIR=$(BUILD_DIR)/iptables-1.2.8